aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd_219.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2015-02-27 14:57:48 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-27 19:02:57 +0000
commita3e9a86c8765a60ef0ef282f0fe3f3c733a8e3a3 (patch)
tree54fe9ff753c75faf805cc0855380611789abf256 /meta/recipes-core/systemd/systemd_219.bb
parent57110cb701f16b59a92efcce1057ba2622e568cf (diff)
downloadopenembedded-core-contrib-a3e9a86c8765a60ef0ef282f0fe3f3c733a8e3a3.tar.gz
systemd: add PACKAGECONFIG for xkbcommon and iptables
systemd has optional support for xkbcommon (verify keymaps when locale changes) and iptables (configure NAT rules). Add PACKAGECONFIG options for these, disabling iptables by default and respecting the X11 DISTRO_FEATURE for libxkbcommon (as the code involves X11 keymaps). Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/systemd/systemd_219.bb')
-rw-r--r--meta/recipes-core/systemd/systemd_219.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta/recipes-core/systemd/systemd_219.bb b/meta/recipes-core/systemd/systemd_219.bb
index 747964e038..f245239c18 100644
--- a/meta/recipes-core/systemd/systemd_219.bb
+++ b/meta/recipes-core/systemd/systemd_219.bb
@@ -55,7 +55,10 @@ LDFLAGS_append_libc-uclibc = " -lrt"
GTKDOC_DOCDIR = "${S}/docs/"
-PACKAGECONFIG ??= "xz ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}"
+PACKAGECONFIG ??= "xz \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xkbcommon', '', d)}"
+
PACKAGECONFIG[journal-upload] = "--enable-libcurl,--disable-libcurl,curl"
# Sign the journal for anti-tampering
PACKAGECONFIG[gcrypt] = "--enable-gcrypt,--disable-gcrypt,libgcrypt"
@@ -73,6 +76,10 @@ PACKAGECONFIG[libidn] = "--enable-libidn,--disable-libidn,libidn"
PACKAGECONFIG[audit] = "--enable-audit,--disable-audit,audit"
PACKAGECONFIG[manpages] = "--enable-manpages,--disable-manpages,libxslt-native xmlto-native docbook-xml-dtd4-native docbook-xsl-stylesheets-native"
PACKAGECONFIG[pam] = "--enable-pam,--disable-pam,libpam"
+# Verify keymaps on locale change
+PACKAGECONFIG[xkbcommon] = "--enable-xkbcommon,--disable-xkbcommon,libxkbcommon"
+# Update NAT firewall rules
+PACKAGECONFIG[iptc] = "--enable-libiptc,--disable-libiptc,iptables"
CACHED_CONFIGUREVARS = "ac_cv_path_KILL=${base_bindir}/kill"