aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd_219.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2015-03-02 15:37:48 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-03-09 16:00:15 +0000
commit060375f0fea327d2962980045666edb6eaa5d5f0 (patch)
tree5944927068d40fcfc6cfca225e8334a9918f8a4a /meta/recipes-core/systemd/systemd_219.bb
parent704fd8f1efbd7fa9368cfe4f956abf24cd58664e (diff)
downloadopenembedded-core-contrib-060375f0fea327d2962980045666edb6eaa5d5f0.tar.gz
systemd: avoid parsing error when 'networkd' is enabled in PACKAGECONFIG
If 'networkd' is enabled in PACKAGECONFIG, the do_install variable cannot be correctly expanded. Error message is like below. Failure expanding variable do_install: ShellSyntaxError: LexToken(Fi,'fi',0,0) followed by: LexToken(NEWLINE,'\n',0,0) This patch fixes the above problem. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-core/systemd/systemd_219.bb')
-rw-r--r--meta/recipes-core/systemd/systemd_219.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/systemd/systemd_219.bb b/meta/recipes-core/systemd/systemd_219.bb
index 24486f1815..d5c14a42c4 100644
--- a/meta/recipes-core/systemd/systemd_219.bb
+++ b/meta/recipes-core/systemd/systemd_219.bb
@@ -170,7 +170,7 @@ do_install() {
# this file is needed to exist if networkd is disabled but timesyncd is still in use since timesyncd checks it
# for existence else it fails
if [ -s ${D}${libdir}/tmpfiles.d/systemd.conf ]; then
- ${@bb.utils.contains('PACKAGECONFIG', 'networkd', '', 'sed -i -e "\$ad /run/systemd/netif/links 0755 root root -" ${D}${libdir}/tmpfiles.d/systemd.conf', d)}
+ ${@bb.utils.contains('PACKAGECONFIG', 'networkd', ':', 'sed -i -e "\$ad /run/systemd/netif/links 0755 root root -" ${D}${libdir}/tmpfiles.d/systemd.conf', d)}
fi
}