aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd_216.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-11-12 18:36:23 +0800
committerChen Qi <Qi.Chen@windriver.com>2014-11-13 15:54:51 +0800
commit9ad835b1a386b20dcad037c4e78e81a9fcd32181 (patch)
tree44ecffa04372484995f53aeb474cc5c75cc35730 /meta/recipes-core/systemd/systemd_216.bb
parent33b7885ecdc8774e34ac3534ec49fed6ffdb3916 (diff)
downloadopenembedded-core-contrib-9ad835b1a386b20dcad037c4e78e81a9fcd32181.tar.gz
systemd: add option for valgrind header checkingChenQi/systemd-valgrindheader
Add option so that valgrind header checking is controlled. Otherwise, we would get the following error. src/libsystemd/sd-bus/bus-control.c: fatal error: valgrind/mencheck.h: No such file or directory The above error could be reproduced by the following command. bitbake valgrind && bitbake systemd -ccleansstate && bitbake systemd -cconfigure && bitbake valgrind -ccleansstate && bitbake systemd -ccompile Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Diffstat (limited to 'meta/recipes-core/systemd/systemd_216.bb')
-rw-r--r--meta/recipes-core/systemd/systemd_216.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd_216.bb b/meta/recipes-core/systemd/systemd_216.bb
index 27a5d926ff..b48bc3a5d3 100644
--- a/meta/recipes-core/systemd/systemd_216.bb
+++ b/meta/recipes-core/systemd/systemd_216.bb
@@ -38,6 +38,7 @@ SRC_URI = "git://anongit.freedesktop.org/systemd/systemd;branch=master;protocol=
file://init \
file://run-ptest \
${@bb.utils.contains('PACKAGECONFIG', 'resolved', '', 'file://0001-tmpfiles.d-etc.conf-disable-resolv.conf-symlink.patch', d)} \
+ file://0001-configure.ac-add-valgrind-header-checking-option.patch \
"
S = "${WORKDIR}/git"
@@ -64,6 +65,7 @@ PACKAGECONFIG[elfutils] = "--enable-elfutils,--disable-elfutils,elfutils"
PACKAGECONFIG[resolved] = "--enable-resolved,--disable-resolved"
PACKAGECONFIG[networkd] = "--enable-networkd,--disable-networkd"
PACKAGECONFIG[libidn] = "--enable-libidn,--disable-libidn,libidn"
+PACKAGECONFIG[valgrindheader] = "--enable-valgrindheader,--disable-valgrindheader,valgrind"
CACHED_CONFIGUREVARS = "ac_cv_path_KILL=${base_bindir}/kill"