aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd
diff options
context:
space:
mode:
authorStefan Müller-Klieser <s.mueller-klieser@phytec.de>2017-05-18 15:25:35 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-25 23:35:50 +0100
commitba71820ea16f2ee990dfca98b390d4ff586b7a49 (patch)
tree203d66dc83373216f06d636d30d528969c5a340e /meta/recipes-core/systemd/systemd
parentf0effea8716faae749a7d15003647d68fa0cabf7 (diff)
downloadopenembedded-core-contrib-ba71820ea16f2ee990dfca98b390d4ff586b7a49.tar.gz
systemd: fix lz4 build
Updating lz4 in oe-core required back porting 3d4cf7de48a from master, as versioning scheme changed. Signed-off-by: Stefan Müller-Klieser <s.mueller-klieser@phytec.de> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-core/systemd/systemd')
-rw-r--r--meta/recipes-core/systemd/systemd/0021-build-sys-check-for-lz4-in-the-old-and-new-numbering.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd/0021-build-sys-check-for-lz4-in-the-old-and-new-numbering.patch b/meta/recipes-core/systemd/systemd/0021-build-sys-check-for-lz4-in-the-old-and-new-numbering.patch
new file mode 100644
index 0000000000..a7d7461bc8
--- /dev/null
+++ b/meta/recipes-core/systemd/systemd/0021-build-sys-check-for-lz4-in-the-old-and-new-numbering.patch
@@ -0,0 +1,51 @@
+From 8200002233bd40acda4bbfb991a31d87f4224fea Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
+Date: Wed, 23 Nov 2016 10:18:30 -0500
+Subject: [PATCH 21/21] build-sys: check for lz4 in the old and new numbering
+ scheme (#4717)
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+lz4 upstream decided to switch to an incompatible numbering scheme
+(1.7.3 follows 131, to match the so version).
+PKG_CHECK_MODULES does not allow two version matches for the same package,
+so e.g. lz4 < 10 || lz4 >= 125 cannot be used. Check twice, once for
+"new" numbers (anything below 10 is assume to be new), once for the "old"
+numbers (anything above >= 125). This assumes that the "new" versioning
+will not get to 10 to quickly. I think that's a safe assumption, lz4 is a
+mature project.
+
+Fixed #4690.
+
+Upstream-Status: Backport
+
+Signed-off-by: Stefan Müller-Klieser <s.mueller-klieser@phytec.de>
+---
+ configure.ac | 9 ++++++---
+ 1 file changed, 6 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 279ce28..782b5d7 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -640,10 +640,13 @@ AM_CONDITIONAL(HAVE_BZIP2, [test "$have_bzip2" = "yes"])
+ have_lz4=no
+ AC_ARG_ENABLE(lz4, AS_HELP_STRING([--disable-lz4], [Disable optional LZ4 support]))
+ AS_IF([test "x$enable_lz4" != "xno"], [
+- PKG_CHECK_MODULES(LZ4, [ liblz4 >= 125 ],
+- [AC_DEFINE(HAVE_LZ4, 1, [Define in LZ4 is available])
++ PKG_CHECK_MODULES(LZ4, [ liblz4 < 10 ],
++ [AC_DEFINE(HAVE_LZ4, 1, [Define if LZ4 is available])
+ have_lz4=yes],
+- have_lz4=no)
++ [PKG_CHECK_MODULES(LZ4, [ liblz4 >= 125 ],
++ [AC_DEFINE(HAVE_LZ4, 1, [Define if LZ4 is available])
++ have_lz4=yes],
++ have_lz4=no)])
+ AS_IF([test "x$have_lz4" = xno -a "x$enable_lz4" = xyes],
+ [AC_MSG_ERROR([*** LZ4 support requested but libraries not found])])
+ ])
+--
+1.9.1
+