aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd-compat-units.bb
diff options
context:
space:
mode:
authorAnders Darander <anders@chargestorm.se>2014-01-10 08:15:03 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-14 11:33:16 +0000
commit5aea3d375b717d96f8f916f2f830e8f8649a4991 (patch)
treeecb6614929b1b3e8d976d002974f99bf3b6f7dd6 /meta/recipes-core/systemd/systemd-compat-units.bb
parent80affbb4e0e79d3cca6022d7426503d7f20ce3ac (diff)
downloadopenembedded-core-contrib-5aea3d375b717d96f8f916f2f830e8f8649a4991.tar.gz
systemd-compat-units: do not mask available services
Do also check systemd_unitdir/system/ for available unit files. This was hiding dnsmasq.service for us, as /etc/systemd/system has priority over systemd_unitdir/system... Signed-off-by: Anders Darander <anders@chargestorm.se> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/systemd/systemd-compat-units.bb')
-rw-r--r--meta/recipes-core/systemd/systemd-compat-units.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/systemd/systemd-compat-units.bb b/meta/recipes-core/systemd/systemd-compat-units.bb
index 9f28283570..e32ad791ec 100644
--- a/meta/recipes-core/systemd/systemd-compat-units.bb
+++ b/meta/recipes-core/systemd/systemd-compat-units.bb
@@ -42,7 +42,7 @@ pkg_postinst_${PN} () {
fi
for i in ${SYSTEMD_DISABLED_SYSV_SERVICES} ; do
- if [ \( -e $i -o $i.sh \) -a ! -e $D${sysconfdir}/systemd/system/$i.service ] ; then
+ if [ \( -e $i -o $i.sh \) -a ! \( -e $D${sysconfdir}/systemd/system/$i.service -o -e $D${systemd_unitdir}/system/$i.service \) ] ; then
echo -n "$i: " ; systemctl ${OPTS} mask $i.service
fi
done ; echo