aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/psplash
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/recipes-core/psplash
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadopenembedded-core-contrib-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/psplash')
-rwxr-xr-xmeta/recipes-core/psplash/files/psplash-init29
-rw-r--r--meta/recipes-core/psplash/psplash_svn.bb26
2 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-core/psplash/files/psplash-init b/meta/recipes-core/psplash/files/psplash-init
new file mode 100755
index 0000000000..66c85e9335
--- /dev/null
+++ b/meta/recipes-core/psplash/files/psplash-init
@@ -0,0 +1,29 @@
+#!/bin/sh
+### BEGIN INIT INFO
+# Provides: psplash
+# Required-Start:
+# Required-Stop:
+# Default-Start: S
+# Default-Stop:
+### END INIT INFO
+
+read CMDLINE < /proc/cmdline
+for x in $CMDLINE; do
+ case $x in
+ psplash=false)
+ echo "Boot splashscreen disabled"
+ exit 0;
+ ;;
+ esac
+done
+
+export TMPDIR=/mnt/.psplash
+mount tmpfs -t tmpfs $TMPDIR -o,size=40k
+
+rotation=0
+if [ -e /etc/rotation ]; then
+ read rotation < /etc/rotation
+fi
+
+/usr/bin/psplash --angle $rotation &
+
diff --git a/meta/recipes-core/psplash/psplash_svn.bb b/meta/recipes-core/psplash/psplash_svn.bb
new file mode 100644
index 0000000000..1e53ef1f1b
--- /dev/null
+++ b/meta/recipes-core/psplash/psplash_svn.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Userspace framebuffer boot logo based on usplash."
+HOMEPAGE = "http://svn.o-hand.com/view/misc/trunk/psplash/"
+SECTION = "base"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://psplash.h;md5=a87c39812c1e37f3451567cc29a29c8f"
+
+PV = "0.0+svnr${SRCREV}"
+PR = "r5"
+
+SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=psplash;proto=http \
+ file://psplash-init"
+
+S = "${WORKDIR}/psplash"
+
+inherit autotools pkgconfig update-rc.d
+
+FILES_${PN} += "/mnt/.psplash"
+
+do_install_prepend() {
+ install -d ${D}/mnt/.psplash/
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/psplash-init ${D}${sysconfdir}/init.d/psplash.sh
+}
+
+INITSCRIPT_NAME = "psplash.sh"
+INITSCRIPT_PARAMS = "start 0 S . stop 20 0 1 6 ."