aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/psplash
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-18 01:32:16 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-18 13:18:24 +0000
commit297f6f5da1b6b9421ae435eb4df3996116e258f0 (patch)
tree30b49ae43173a7fd51394696a392e7585b3fce74 /meta/recipes-core/psplash
parente924d5bbe796db8c35d375c3ab457f29ba795375 (diff)
downloadopenembedded-core-contrib-297f6f5da1b6b9421ae435eb4df3996116e258f0.tar.gz
psplash: Fix case where ${B} != ${S}
Allow out of tree builds to work by using the full path to the source file. (From OE-Core rev: 4ddb7b870a2ddbf48ebf1ec2e454dc7421285202) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/psplash')
-rw-r--r--meta/recipes-core/psplash/psplash_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/psplash/psplash_git.bb b/meta/recipes-core/psplash/psplash_git.bb
index 482670d0b4..5413b24057 100644
--- a/meta/recipes-core/psplash/psplash_git.bb
+++ b/meta/recipes-core/psplash/psplash_git.bb
@@ -87,7 +87,7 @@ python do_compile () {
shutil.copyfile(localfile, destfile)
# For some reason just updating the header is not enough, we have to touch the .c
# file in order to get it to rebuild
- os.utime("psplash.c", None)
+ os.utime("%s/psplash.c" % d.getVar('S', True), None)
bb.build.exec_func("oe_runmake", d)
shutil.copyfile("psplash", outputfile)
}