aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/psplash
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2013-03-26 22:16:26 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-27 11:06:58 +0000
commitc433a1b78c407bea17747cb77f5332ed8ee4c5e7 (patch)
tree27c6b12777ae59636d327a56e2010bc8aacf61b6 /meta/recipes-core/psplash
parent6a2c86fc639dac12e76d8943ea380710164b46d6 (diff)
downloadopenembedded-core-contrib-c433a1b78c407bea17747cb77f5332ed8ee4c5e7.tar.gz
psplash_git.bb: fix do_compile by correcting the script path
The recent change in the builddir location is breaking this recipe as it is trying to run a script (make-image-header.sh) located in sourcedir from builddir. As the script does not gets to run, the resulting file is not generated causing error as seen below. This commit fixes the issue, by providing complete path of the script. This commit fixes this build error: ERROR: Error executing a python function in /srv/home/nitin/prj/poky.git/meta/recipes-core/psplash/psplash_git.bb: IOError: [Errno 2] No such file or directory: 'psplash-tlk-img.h' ERROR: Task 6 (/srv/home/nitin/prj/poky.git/meta/recipes-core/psplash/psplash_git.bb, do_compile) failed with exit code '1' Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/psplash')
-rw-r--r--meta/recipes-core/psplash/psplash_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-core/psplash/psplash_git.bb b/meta/recipes-core/psplash/psplash_git.bb
index 5413b24057..2d0cae371d 100644
--- a/meta/recipes-core/psplash/psplash_git.bb
+++ b/meta/recipes-core/psplash/psplash_git.bb
@@ -74,12 +74,13 @@ python do_compile () {
import shutil, commands
# Build a separate executable for each splash image
+ convertscript = "%s/make-image-header.sh" % d.getVar('S', True)
destfile = "%s/psplash-poky-img.h" % d.getVar('S', True)
localfiles = d.getVar('SPLASH_LOCALPATHS', True).split()
outputfiles = d.getVar('SPLASH_INSTALL', True).split()
for localfile, outputfile in zip(localfiles, outputfiles):
if localfile.endswith(".png"):
- outp = commands.getstatusoutput('./make-image-header.sh %s POKY' % localfile)
+ outp = commands.getstatusoutput('%s %s POKY' % (convertscript, localfile))
print(outp[1])
fbase = os.path.splitext(os.path.basename(localfile))[0]
shutil.copyfile("%s-img.h" % fbase, destfile)