summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/psplash/psplash_git.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-05-07 13:56:05 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-05-09 14:04:19 +0100
commite2e1dcd74bc45381baccf507c0309dd792229afe (patch)
tree71bca48bffd9feacc6bd8e2beb9c5a625ee1b297 /meta/recipes-core/psplash/psplash_git.bb
parent4f47b3a4726dd47e8a6db228fcaf25d1890e3e52 (diff)
downloadopenembedded-core-contrib-e2e1dcd74bc45381baccf507c0309dd792229afe.tar.gz
sanity/patch.py: Remove commands module usage
The commands module is removed in python3. Use the subprocess module instead and the pipes module to replace the mkargs usage. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/psplash/psplash_git.bb')
-rw-r--r--meta/recipes-core/psplash/psplash_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-core/psplash/psplash_git.bb b/meta/recipes-core/psplash/psplash_git.bb
index bbeaa0b3b9..392fada689 100644
--- a/meta/recipes-core/psplash/psplash_git.bb
+++ b/meta/recipes-core/psplash/psplash_git.bb
@@ -71,7 +71,7 @@ ALTERNATIVE_PRIORITY = "100"
ALTERNATIVE_LINK_NAME[psplash] = "${bindir}/psplash"
python do_compile () {
- import shutil, commands
+ import shutil, subprocess
# Build a separate executable for each splash image
convertscript = "%s/make-image-header.sh" % d.getVar('S', True)
@@ -80,7 +80,7 @@ python do_compile () {
outputfiles = d.getVar('SPLASH_INSTALL', True).split()
for localfile, outputfile in zip(localfiles, outputfiles):
if localfile.endswith(".png"):
- outp = commands.getstatusoutput('%s %s POKY' % (convertscript, localfile))
+ outp = subprocess.getstatusoutput('%s %s POKY' % (convertscript, localfile))
print(outp[1])
fbase = os.path.splitext(os.path.basename(localfile))[0]
shutil.copyfile("%s-img.h" % fbase, destfile)