aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/os-release
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-25 17:58:55 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-30 12:34:22 +0100
commit9585cffea33895c3ceea30f45325d2eca6dcf1c2 (patch)
tree418f8b2e810ce26748b5128f41ac4409547fdbd3 /meta/recipes-core/os-release
parent0b5e868d160faca041cda42b670066facd4db531 (diff)
downloadopenembedded-core-contrib-9585cffea33895c3ceea30f45325d2eca6dcf1c2.tar.gz
os-release: Exclude DATETIME from sstate signature
I'm torn over this, I can see someone wanting this to vary in each build. What pushed me to believe its incorrect in its current form is that it changes for every MACHINE build, making a complete mess if you try and generate package feeds using it. The alternative would be to give up on allarch in this case and make it MACHINE specific which at least would then be more consistent when the package makes it to a package feed. If someone wants to do that, the can propose another patch but this change at least make package feed usage 'sane' again and avoids the perpetual rebuilds. Incidentally, its worth noting that changes in source metadata revision used for the build and included in this recipe would still trigger rebuilds which is likely the common use case people actually care about. (From OE-Core rev: 46de6f6eb9c4387298fafb48fb9c36abc3ff48a4) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/os-release')
-rw-r--r--meta/recipes-core/os-release/os-release.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-core/os-release/os-release.bb b/meta/recipes-core/os-release/os-release.bb
index 87fea6f04d..10a4570492 100644
--- a/meta/recipes-core/os-release/os-release.bb
+++ b/meta/recipes-core/os-release/os-release.bb
@@ -21,6 +21,7 @@ VERSION = "${DISTRO_VERSION}${@' (%s)' % DISTRO_CODENAME if 'DISTRO_CODENAME' in
VERSION_ID = "${DISTRO_VERSION}"
PRETTY_NAME = "${DISTRO_NAME} ${VERSION}"
BUILD_ID ?= "${DATETIME}"
+BUILD_ID[vardepsexclude] = "DATETIME"
python do_compile () {
with open(d.expand('${B}/os-release'), 'w') as f: