aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/musl
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-09-13 07:04:26 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-09-17 08:39:19 +0100
commita5b0265e83f3c5a222c1b08bc853bec40e5a5148 (patch)
tree185e7b4490ba13af99f0dc8e4240f3899b0205f3 /meta/recipes-core/musl
parenta74faf487545df16c7395ee6f6a302f989c1341b (diff)
downloadopenembedded-core-contrib-a5b0265e83f3c5a222c1b08bc853bec40e5a5148.tar.gz
musl: Add MAX_HANDLE_SZ
(From OE-Core rev: d24bafa872cd1915ca23468bb37be98518347e02) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/musl')
-rw-r--r--meta/recipes-core/musl/musl/0001-Define-MAX_HANDLE_SZ.patch29
-rw-r--r--meta/recipes-core/musl/musl_git.bb1
2 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-core/musl/musl/0001-Define-MAX_HANDLE_SZ.patch b/meta/recipes-core/musl/musl/0001-Define-MAX_HANDLE_SZ.patch
new file mode 100644
index 0000000000..b1217723a3
--- /dev/null
+++ b/meta/recipes-core/musl/musl/0001-Define-MAX_HANDLE_SZ.patch
@@ -0,0 +1,29 @@
+From e2e723cfe96ce6ed6558ed7e8fbb44b2283297da Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 13 Sep 2018 06:57:28 -0700
+Subject: [PATCH] Define MAX_HANDLE_SZ
+
+MAX_HANDLE_SZ is described in name_to_handle_at() to contain maximum
+expected size for a file handle
+
+Upstream-Status: Submitted [https://www.openwall.com/lists/musl/2018/09/13/16]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ include/fcntl.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/include/fcntl.h b/include/fcntl.h
+index 5c3defcb..6a8b6d49 100644
+--- a/include/fcntl.h
++++ b/include/fcntl.h
+@@ -166,6 +166,7 @@ struct f_owner_ex {
+ };
+ #define FALLOC_FL_KEEP_SIZE 1
+ #define FALLOC_FL_PUNCH_HOLE 2
++#define MAX_HANDLE_SZ 128
+ #define SYNC_FILE_RANGE_WAIT_BEFORE 1
+ #define SYNC_FILE_RANGE_WRITE 2
+ #define SYNC_FILE_RANGE_WAIT_AFTER 4
+--
+2.19.0
+
diff --git a/meta/recipes-core/musl/musl_git.bb b/meta/recipes-core/musl/musl_git.bb
index f6edf7de61..be31718e3a 100644
--- a/meta/recipes-core/musl/musl_git.bb
+++ b/meta/recipes-core/musl/musl_git.bb
@@ -12,6 +12,7 @@ PV = "1.1.20+git${SRCPV}"
SRC_URI = "git://git.musl-libc.org/musl \
file://0001-Make-dynamic-linker-a-relative-symlink-to-libc.patch \
file://0001-wireup-linux-name_to_handle_at-and-name_to_handle_at.patch \
+ file://0001-Define-MAX_HANDLE_SZ.patch \
"
S = "${WORKDIR}/git"