aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/musl/bsd-headers.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-03-02 09:52:53 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-04 11:34:58 +0000
commit220d7451f65cb2e32a06503e36075889c63b0bd9 (patch)
treee09d1c1c3aa58beff73bbd0c269705e46e17361a /meta/recipes-core/musl/bsd-headers.bb
parent91829d07cdeb42e213500e053e20a9db68848d2e (diff)
downloadopenembedded-core-contrib-220d7451f65cb2e32a06503e36075889c63b0bd9.tar.gz
bsd-headers: Move next to musl recipes
This helps communicate the dependency a bit better Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-core/musl/bsd-headers.bb')
-rw-r--r--meta/recipes-core/musl/bsd-headers.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-core/musl/bsd-headers.bb b/meta/recipes-core/musl/bsd-headers.bb
new file mode 100644
index 0000000000..c9945d45eb
--- /dev/null
+++ b/meta/recipes-core/musl/bsd-headers.bb
@@ -0,0 +1,31 @@
+# Copyright (C) 2016 Khem Raj <raj.khem@gmail.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SUMMARY = "BSD compatible headers"
+LICENSE = "BSD-3-Clause & BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://sys-queue.h;beginline=1;endline=32;md5=c6352b0f03bb448600456547d334b56f"
+SECTION = "devel"
+
+SRC_URI = "file://sys-queue.h \
+ file://sys-tree.h \
+ file://sys-cdefs.h \
+ "
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+INHIBIT_DEFAULT_DEPS = "1"
+
+S = "${WORKDIR}"
+
+do_install() {
+ install -Dm 0644 ${S}/sys-queue.h ${D}${includedir}/sys/queue.h
+ install -Dm 0644 ${S}/sys-tree.h ${D}${includedir}/sys/tree.h
+ install -Dm 0644 ${S}/sys-cdefs.h ${D}${includedir}/sys/cdefs.h
+}
+#
+# We will skip parsing for non-musl systems
+#
+
+COMPATIBLE_HOST = ".*-musl.*"
+RDEPENDS_${PN}-dev = ""
+RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"