aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta
diff options
context:
space:
mode:
authorKristian Amlie <kristian.amlie@mender.io>2017-01-30 16:43:38 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-02-02 17:37:33 +0000
commitfc59d35a8ceae6302e0a161bab04829fdfd157cd (patch)
tree07e2ee78a1d814a737b77a06acfe9074b44f9775 /meta/recipes-core/meta
parentcbfb41100dbe1973903d7f2b9b4a133bf51e40c1 (diff)
downloadopenembedded-core-contrib-fc59d35a8ceae6302e0a161bab04829fdfd157cd.tar.gz
wic-tools: Do not remove sysroot with rm_work, because wic needs it.
The sysroot of wic-tools is needed for wic, but if rm_work is enabled, it will be removed before wic has a chance to use it, hence this fix. Signed-off-by: Kristian Amlie <kristian.amlie@mender.io> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-core/meta')
-rw-r--r--meta/recipes-core/meta/wic-tools.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/wic-tools.bb b/meta/recipes-core/meta/wic-tools.bb
index 1d9ea9c0e9..bd4319a803 100644
--- a/meta/recipes-core/meta/wic-tools.bb
+++ b/meta/recipes-core/meta/wic-tools.bb
@@ -9,6 +9,10 @@ DEPENDS_append_x86-64 = " syslinux grub-efi systemd-boot"
INHIBIT_DEFAULT_DEPS = "1"
inherit nopackages
+# The sysroot of wic-tools is needed for wic, but if rm_work is enabled, it will
+# be removed before wic has a chance to use it, hence the exclusion below.
+RM_WORK_EXCLUDE += "${PN}"
+
python do_build_sysroot () {
bb.build.exec_func("extend_recipe_sysroot", d)