summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta
diff options
context:
space:
mode:
authorPeter Marko <peter.marko@siemens.com>2023-07-11 08:36:29 +0200
committerSteve Sakoman <steve@sakoman.com>2023-07-13 06:39:45 -1000
commiteceeba61b5da6d81f0677365f956464f1e5f1d84 (patch)
tree177ca079f79de0d944150543028fff1147c920a3 /meta/recipes-core/meta
parentc061bcd54fc8b62ea9a005f422a17ca46eac68c2 (diff)
downloadopenembedded-core-contrib-eceeba61b5da6d81f0677365f956464f1e5f1d84.tar.gz
cve-update-nvd2-native: increase retry count
Current 503 errors seem to last several seconds. In most cases there are two errors and third request succeeds. However sometimes the outage takes more than time needed for two retries and third one also fails. Extend retry count from 3 to 5 to improve the probablity that the fetcher succeeds. Signed-off-by: Peter Marko <peter.marko@siemens.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit f4d118af2360cff7f234102fd5e4b65a6f4146a6) Signed-off-by: Steve Sakoman <steve@sakoman.com>
Diffstat (limited to 'meta/recipes-core/meta')
-rw-r--r--meta/recipes-core/meta/cve-update-nvd2-native.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/meta/cve-update-nvd2-native.bb b/meta/recipes-core/meta/cve-update-nvd2-native.bb
index e2584d21b3..8e5b83d7f1 100644
--- a/meta/recipes-core/meta/cve-update-nvd2-native.bb
+++ b/meta/recipes-core/meta/cve-update-nvd2-native.bb
@@ -129,7 +129,7 @@ def nvd_request_next(url, api_key, args):
full_request = url + '?' + data
- for attempt in range(3):
+ for attempt in range(5):
try:
r = urllib.request.urlopen(full_request)