aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2013-08-02 11:37:08 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-06 12:39:53 +0100
commit2fd2c606f6747145c4923a59ad9aa2b1d63d910f (patch)
tree8625c519808889a117c89bd9c1f999677df41830 /meta/recipes-core/meta
parentca365c603b72e29fa028d6e83a8ca42b1d115f1e (diff)
downloadopenembedded-core-contrib-2fd2c606f6747145c4923a59ad9aa2b1d63d910f.tar.gz
buildtools-tarball: do not export OECORE_NATIVE_SYSROOT
When building a qemu image inside the environment created by the buildtools-tarball, the qemu image cannot be started, as the runqemu script uses the tunctl binary which cannot be found inside the sysroot directory of the buildtools-tarball. The buildtools-tarball is inherently a tool set instead of a fully functional SDK, so leaving the OECORE_NATIVE_SYSROOT variable in the environment will mess things up. However, we do need a line of 'OECORE_NATIVE_SYSROOT=xxx' in the environment setup script so that the SDK can be extracted and relocated correctly. Thus, instead of exporting OECORE_NATIVE_SYSROOT, we use a comment here. [YOCTO #4939] (From OE-Core rev: d4a4c764a844a7e61f866af9361f139684037336) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/meta')
-rw-r--r--meta/recipes-core/meta/buildtools-tarball.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/meta/recipes-core/meta/buildtools-tarball.bb b/meta/recipes-core/meta/buildtools-tarball.bb
index 9771497ea5..1e46308d3d 100644
--- a/meta/recipes-core/meta/buildtools-tarball.bb
+++ b/meta/recipes-core/meta/buildtools-tarball.bb
@@ -59,7 +59,10 @@ create_sdk_files_append () {
script=${1:-${SDK_OUTPUT}/${SDKPATH}/environment-setup-${SDK_SYS}}
touch $script
echo 'export PATH=${SDKPATHNATIVE}${bindir_nativesdk}:$PATH' >> $script
- echo 'export OECORE_NATIVE_SYSROOT="${SDKPATHNATIVE}"' >> $script
-
+ # In order for the self-extraction script to correctly extract and set up things,
+ # we need a 'OECORE_NATIVE_SYSROOT=xxx' line in environment setup script.
+ # However, buildtools-tarball is inherently a tool set instead of a fully functional SDK,
+ # so instead of exporting the variable, we use a comment here.
+ echo '#OECORE_NATIVE_SYSROOT="${SDKPATHNATIVE}"' >> $script
toolchain_create_sdk_version ${SDK_OUTPUT}/${SDKPATH}/version-${SDK_SYS}
}