summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-23 18:05:16 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-23 18:06:03 +0100
commit1dbc6ec4ca061570d2482c9abebcf720298db9b7 (patch)
tree85da63db1d5cd4fe16a32e0f64648255e9452c8b /meta/recipes-core/meta
parent8d6ee36493800a30e9bd6eacb671fbafe5d61ad7 (diff)
downloadopenembedded-core-contrib-1dbc6ec4ca061570d2482c9abebcf720298db9b7.tar.gz
buildtools/uninative-tarball: Fix deployment overlap issues
We still have problems where deploying SDKMACHINE=i686 can cause removal of SDKMACHINE=x86_64 artefacts. The reason is that x86_64 is a BUILD_ARCH as well as an SDK_ARCH and the manifest namespaces overlap. To fix this, set PACKAGE_ARCH and the stamp-extra-into to include SDK_OS. SDK_OS may not be entirely correct but it is what sstate.bbclass uses for nativesdk and fixing that is a separate issue. This is confirmed to resolve artefact problems on the AB which have been delaying a new uninative release. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/meta')
-rw-r--r--meta/recipes-core/meta/buildtools-tarball.bb4
-rw-r--r--meta/recipes-core/meta/uninative-tarball.bb4
2 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-core/meta/buildtools-tarball.bb b/meta/recipes-core/meta/buildtools-tarball.bb
index da18c09fce..5808c95d81 100644
--- a/meta/recipes-core/meta/buildtools-tarball.bb
+++ b/meta/recipes-core/meta/buildtools-tarball.bb
@@ -27,7 +27,7 @@ TOOLCHAIN_HOST_TASK ?= "\
"
MULTIMACH_TARGET_SYS = "${SDK_ARCH}-nativesdk${SDK_VENDOR}-${SDK_OS}"
-PACKAGE_ARCH = "${SDK_ARCH}"
+PACKAGE_ARCH = "${SDK_ARCH}_${SDK_OS}"
PACKAGE_ARCHS = ""
TARGET_ARCH = "none"
TARGET_OS = "none"
@@ -52,7 +52,7 @@ deltask package
deltask packagedata
deltask populate_sysroot
-do_populate_sdk[stamp-extra-info] = "${SDKMACHINE}"
+do_populate_sdk[stamp-extra-info] = "${PACKAGE_ARCH}"
REAL_MULTIMACH_TARGET_SYS = "none"
diff --git a/meta/recipes-core/meta/uninative-tarball.bb b/meta/recipes-core/meta/uninative-tarball.bb
index 0dad974238..e203a8322e 100644
--- a/meta/recipes-core/meta/uninative-tarball.bb
+++ b/meta/recipes-core/meta/uninative-tarball.bb
@@ -17,7 +17,7 @@ TOOLCHAIN_HOST_TASK = "\
INHIBIT_DEFAULT_DEPS = "1"
MULTIMACH_TARGET_SYS = "${SDK_ARCH}-nativesdk${SDK_VENDOR}-${SDK_OS}"
-PACKAGE_ARCH = "${SDK_ARCH}"
+PACKAGE_ARCH = "${SDK_ARCH}_${SDK_OS}"
PACKAGE_ARCHS = ""
TARGET_ARCH = "none"
TARGET_OS = "none"
@@ -37,7 +37,7 @@ deltask package
deltask packagedata
deltask populate_sysroot
-do_populate_sdk[stamp-extra-info] = "${SDKMACHINE}"
+do_populate_sdk[stamp-extra-info] = "${PACKAGE_ARCH}"
SDK_DEPENDS += "patchelf-native"