aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-02-25 16:59:39 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-28 11:32:38 +0000
commit11b0e7e1cb29fd1fbe06bdb5606a55b92ecdcc89 (patch)
treef0909e7d39b69b21e4261b982f1d22fd5806e597 /meta/recipes-core/meta
parent74c28b2719f0e1723c5ee0f885955412ea229a73 (diff)
downloadopenembedded-core-contrib-11b0e7e1cb29fd1fbe06bdb5606a55b92ecdcc89.tar.gz
uninative-tarball: respect SDKMACHINE when building
So that a single machine can build multiple architectures for the uninative-tarball respect SDK_ARCH instead of BUILD_ARCH. This means a x86-64 host can build a i686 uninative-tarball by setting SDKMACHINE=i686. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-core/meta')
-rw-r--r--meta/recipes-core/meta/uninative-tarball.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/meta/recipes-core/meta/uninative-tarball.bb b/meta/recipes-core/meta/uninative-tarball.bb
index 21f3bd9859..ab1015fcfa 100644
--- a/meta/recipes-core/meta/uninative-tarball.bb
+++ b/meta/recipes-core/meta/uninative-tarball.bb
@@ -13,7 +13,7 @@ TOOLCHAIN_HOST_TASK = "\
INHIBIT_DEFAULT_DEPS = "1"
-TOOLCHAIN_OUTPUTNAME ?= "${BUILD_ARCH}-nativesdk-libc"
+TOOLCHAIN_OUTPUTNAME ?= "${SDK_ARCH}-nativesdk-libc"
RDEPENDS = "${TOOLCHAIN_HOST_TASK}"
@@ -43,9 +43,11 @@ fakeroot create_sdk_files() {
fakeroot tar_sdk() {
mkdir -p ${SDK_DEPLOY}
cd ${SDK_OUTPUT}/${SDKPATH}
- mv sysroots/${SDK_SYS} ./${BUILD_SYS}
+
+ DEST="./${SDK_ARCH}-${SDK_OS}"
+ mv sysroots/${SDK_SYS} $DEST
rm sysroots -rf
- patchelf --set-interpreter ${@''.join('a' for n in xrange(1024))} ./${BUILD_SYS}/usr/bin/patchelf
- mv ./${BUILD_SYS}/usr/bin/patchelf ./${BUILD_SYS}/usr/bin/patchelf-uninative
+ patchelf --set-interpreter ${@''.join('a' for n in xrange(1024))} $DEST/usr/bin/patchelf
+ mv $DEST/usr/bin/patchelf $DEST/usr/bin/patchelf-uninative
tar ${SDKTAROPTS} -c -j --file=${SDK_DEPLOY}/${TOOLCHAIN_OUTPUTNAME}.tar.bz2 .
}