aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/package-index.bb
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei@gherzan.ro>2012-04-11 17:26:16 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-13 16:01:16 +0100
commit230b235329bcaca1a95afd89801d28768aff483b (patch)
treefc1a13142b2aad03b24bf96202e20a04d4929712 /meta/recipes-core/meta/package-index.bb
parent164475b9669dc99c14461e1d749ec0626c62cb71 (diff)
downloadopenembedded-core-contrib-230b235329bcaca1a95afd89801d28768aff483b.tar.gz
package-index: Force NATIVE python to use modules from STAGING_DIR_NATIVE
Export PYTHONHOME to ${STAGING_DIR_NATIVE}/usr. In this way python will search for modules in native sysroot. [YOCTO #2134] Signed-off-by: Andrei Gherzan <andrei@gherzan.ro> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/meta/package-index.bb')
-rw-r--r--meta/recipes-core/meta/package-index.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/package-index.bb b/meta/recipes-core/meta/package-index.bb
index bf3922f6d1..96d54e3664 100644
--- a/meta/recipes-core/meta/package-index.bb
+++ b/meta/recipes-core/meta/package-index.bb
@@ -21,6 +21,9 @@ do_populate_sysroot[noexec] = "1"
do_package_index[nostamp] = "1"
do_package_index[depends] += "${PACKAGEINDEXDEPS}"
+# Force NATIVE python to use modules from STAGING_DIR_NATIVE
+export PYTHONHOME = "${STAGING_DIR_NATIVE}/usr"
+
do_package_index() {
set -ex
${PACKAGEINDEXES}