aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/meta-environment.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-09-29 17:44:53 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-09-29 17:46:28 +0100
commit17229152453a8633b2cd63b429f98cc7c192f300 (patch)
tree474f2871aa33ab28a5ad1e7fc8b41d061a14b7a6 /meta/recipes-core/meta/meta-environment.bb
parentf7ffeb39d42c4b99dfd1522af00a674d38ca0579 (diff)
downloadopenembedded-core-contrib-17229152453a8633b2cd63b429f98cc7c192f300.tar.gz
meta-environment: Two critical fixes to unbreak toolchains
Firstly, when multilib builds were being used, the same output files were used in each case, being overwritten each time due to the fact that REAL_MULTIMACH_TARGET_SYS has been expanded. Instead of immediate expansion, just use assignment. This overrides the problematic define in toolchain-scripts.bbclass but allows the multilib code to work. Secondly, the target sysroot was being defined incorrectly which this patch fixes. This was breaking the toolchains. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/meta/meta-environment.bb')
-rw-r--r--meta/recipes-core/meta/meta-environment.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-core/meta/meta-environment.bb b/meta/recipes-core/meta/meta-environment.bb
index c6d3bb8d1c..bd90f9fd7c 100644
--- a/meta/recipes-core/meta/meta-environment.bb
+++ b/meta/recipes-core/meta/meta-environment.bb
@@ -6,14 +6,14 @@ PR = "r8"
EXCLUDE_FROM_WORLD = "1"
-REAL_MULTIMACH_TARGET_SYS := "${TUNE_PKGARCH}${TARGET_VENDOR}-${TARGET_OS}"
+REAL_MULTIMACH_TARGET_SYS = "${TUNE_PKGARCH}${TARGET_VENDOR}-${TARGET_OS}"
inherit toolchain-scripts
TOOLCHAIN_NEED_CONFIGSITE_CACHE += "zlib"
SDK_DIR = "${WORKDIR}/sdk"
SDK_OUTPUT = "${SDK_DIR}/image"
-SDKTARGETSYSROOT = "${SDKPATH}/sysroots/${TARGET_SYS}"
+SDKTARGETSYSROOT = "${SDKPATH}/sysroots/${REAL_MULTIMACH_TARGET_SYS}"
inherit cross-canadian