aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/meta-environment-extsdk.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2017-01-20 07:29:16 +1300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-19 22:45:54 +0000
commit4fe60d526a94f30b201c434994e80fef0f7392f0 (patch)
treecd9356c2201c298cec2bf5abfe4aa3334250050f /meta/recipes-core/meta/meta-environment-extsdk.bb
parentedde4c52872fbd089f85b10b94db4d6ef1796be5 (diff)
downloadopenembedded-core-contrib-4fe60d526a94f30b201c434994e80fef0f7392f0.tar.gz
classes/populate_sdk_ext: force a known value for TMPDIR
If TMPDIR is configured to be somewhere outside of TOPDIR (a not uncommon configuration where you have multiple disks and space on /home is at a premium) then our attempt to find out the location of paths under TMPDIR by using a relative path led to horribly broken paths ending up in the eSDK. To save pain, just force a known value for TMPDIR (i.e. ${TOPDIR}/tmp) and then we can assume that everywhere else. Fixes [YOCTO #10797]. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/meta/meta-environment-extsdk.bb')
-rw-r--r--meta/recipes-core/meta/meta-environment-extsdk.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-core/meta/meta-environment-extsdk.bb b/meta/recipes-core/meta/meta-environment-extsdk.bb
index 76d2661b10..757afc154f 100644
--- a/meta/recipes-core/meta/meta-environment-extsdk.bb
+++ b/meta/recipes-core/meta/meta-environment-extsdk.bb
@@ -5,8 +5,8 @@ require meta-environment.bb
PN = "meta-environment-extsdk-${MACHINE}"
create_sdk_files_append() {
- local sysroot=${SDKPATH}/${@os.path.relpath(d.getVar('STAGING_DIR_TARGET'), d.getVar('TOPDIR'))}
- local sdkpathnative=${SDKPATH}/${@os.path.relpath(d.getVar('STAGING_DIR_NATIVE'), d.getVar('TOPDIR'))}
+ local sysroot=${SDKPATH}/tmp/${@os.path.relpath(d.getVar('STAGING_DIR_TARGET'), d.getVar('TMPDIR'))}
+ local sdkpathnative=${SDKPATH}/tmp/${@os.path.relpath(d.getVar('STAGING_DIR_NATIVE'), d.getVar('TMPDIR'))}
toolchain_create_sdk_env_script '' '' $sysroot '' ${bindir_native} ${prefix_native} $sdkpathnative
}