aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/buildtools-tarball.bb
diff options
context:
space:
mode:
authorJuro Bystricky <juro.bystricky@intel.com>2015-12-03 15:09:55 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-12 23:31:41 +0000
commit1c20e66428df10000741c25dddb7a2b1fd55ba42 (patch)
treec52c5106c983290abde7e8a1e6f503ff5db3f903 /meta/recipes-core/meta/buildtools-tarball.bb
parent36c225704daa58b98a4b7f2ef315eb944d8628b5 (diff)
downloadopenembedded-core-contrib-1c20e66428df10000741c25dddb7a2b1fd55ba42.tar.gz
buildtools-tarball.bb: 32bit tools need pseudo 32bit library
"pseudo" does not build 32 bit library by default on 64 bit host, but the 32 bit library is needed when using 32 bit development tools (buildtools-tarball) running on a 64 bit host. Building of the library can be forced if the environment variable NO32LIBS is set to "0". Hence for 32 bit buildtools we export the environment variable NO32LIBS="0" and NO32LIBS is also added into BB_ENV_EXTRAWHITE (if not already there). [YOCTO#8581] Signed-off-by: Juro Bystricky <juro.bystricky@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-core/meta/buildtools-tarball.bb')
-rw-r--r--meta/recipes-core/meta/buildtools-tarball.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/buildtools-tarball.bb b/meta/recipes-core/meta/buildtools-tarball.bb
index 840434ccd2..8ad4e91ae4 100644
--- a/meta/recipes-core/meta/buildtools-tarball.bb
+++ b/meta/recipes-core/meta/buildtools-tarball.bb
@@ -56,4 +56,10 @@ create_sdk_files_append () {
toolchain_create_sdk_version ${SDK_OUTPUT}/${SDKPATH}/version-${SDK_SYS}
echo 'export GIT_SSL_CAINFO="${SDKPATHNATIVE}${sysconfdir}/ssl/certs/ca-certificates.crt"' >>$script
+
+ if [ ${SDKMACHINE} = "i686" ]; then
+ echo 'export NO32LIBS="0"' >>$script
+ echo 'echo "$BB_ENV_EXTRAWHITE" | grep -q "NO32LIBS"' >>$script
+ echo '[ $? != 0 ] && export BB_ENV_EXTRAWHITE="NO32LIBS $BB_ENV_EXTRAWHITE"' >>$script
+ fi
}