aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/buildtools-tarball.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2013-08-02 11:37:08 +0800
committerSaul Wold <sgw@linux.intel.com>2013-08-05 23:59:54 -0700
commitd4a4c764a844a7e61f866af9361f139684037336 (patch)
tree0120f02b96352aaad7fd5bfbdf810aae6bd698d0 /meta/recipes-core/meta/buildtools-tarball.bb
parente6039e6e3b98d6ab91252a5012d76279b1fac6e8 (diff)
downloadopenembedded-core-contrib-d4a4c764a844a7e61f866af9361f139684037336.tar.gz
buildtools-tarball: do not export OECORE_NATIVE_SYSROOT
When building a qemu image inside the environment created by the buildtools-tarball, the qemu image cannot be started, as the runqemu script uses the tunctl binary which cannot be found inside the sysroot directory of the buildtools-tarball. The buildtools-tarball is inherently a tool set instead of a fully functional SDK, so leaving the OECORE_NATIVE_SYSROOT variable in the environment will mess things up. However, we do need a line of 'OECORE_NATIVE_SYSROOT=xxx' in the environment setup script so that the SDK can be extracted and relocated correctly. Thus, instead of exporting OECORE_NATIVE_SYSROOT, we use a comment here. [YOCTO #4939] Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/meta/buildtools-tarball.bb')
-rw-r--r--meta/recipes-core/meta/buildtools-tarball.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/meta/recipes-core/meta/buildtools-tarball.bb b/meta/recipes-core/meta/buildtools-tarball.bb
index 9771497ea5..1e46308d3d 100644
--- a/meta/recipes-core/meta/buildtools-tarball.bb
+++ b/meta/recipes-core/meta/buildtools-tarball.bb
@@ -59,7 +59,10 @@ create_sdk_files_append () {
script=${1:-${SDK_OUTPUT}/${SDKPATH}/environment-setup-${SDK_SYS}}
touch $script
echo 'export PATH=${SDKPATHNATIVE}${bindir_nativesdk}:$PATH' >> $script
- echo 'export OECORE_NATIVE_SYSROOT="${SDKPATHNATIVE}"' >> $script
-
+ # In order for the self-extraction script to correctly extract and set up things,
+ # we need a 'OECORE_NATIVE_SYSROOT=xxx' line in environment setup script.
+ # However, buildtools-tarball is inherently a tool set instead of a fully functional SDK,
+ # so instead of exporting the variable, we use a comment here.
+ echo '#OECORE_NATIVE_SYSROOT="${SDKPATHNATIVE}"' >> $script
toolchain_create_sdk_version ${SDK_OUTPUT}/${SDKPATH}/version-${SDK_SYS}
}