aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/libxcrypt
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-05-17 09:11:34 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-29 21:06:00 +0100
commitb02ac5dd2dc27fe742cb7f20a12090eda3190c84 (patch)
tree991deb34d1be92d4bd4913ea85d9ad8b55acda57 /meta/recipes-core/libxcrypt
parent10cb11fe911473a3a2f4cb67815ff86141c0ab3c (diff)
downloadopenembedded-core-contrib-b02ac5dd2dc27fe742cb7f20a12090eda3190c84.tar.gz
libxcrypt: Upgrade to 4.0.1
Minor release primary fixes are * get it building with gcc8 * Fixes for riscv64 drop local gcc8 support patch which is not needed now Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-core/libxcrypt')
-rw-r--r--meta/recipes-core/libxcrypt/libxcrypt/0001-disable-format-truncation-warning-with-gcc-8.patch36
-rw-r--r--meta/recipes-core/libxcrypt/libxcrypt_4.0.1.bb (renamed from meta/recipes-core/libxcrypt/libxcrypt_4.0.0.bb)3
2 files changed, 1 insertions, 38 deletions
diff --git a/meta/recipes-core/libxcrypt/libxcrypt/0001-disable-format-truncation-warning-with-gcc-8.patch b/meta/recipes-core/libxcrypt/libxcrypt/0001-disable-format-truncation-warning-with-gcc-8.patch
deleted file mode 100644
index 654eae6c6a..0000000000
--- a/meta/recipes-core/libxcrypt/libxcrypt/0001-disable-format-truncation-warning-with-gcc-8.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From c8c5908611e44a649489e8d217528fedc4864e14 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 10 May 2018 13:32:20 -0700
-Subject: [PATCH] disable format-truncation warning with gcc-8
-
-Upstream-Status: Pending
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- crypt-sunmd5.c | 6 ++++++
- 1 file changed, 6 insertions(+)
-
-diff --git a/crypt-sunmd5.c b/crypt-sunmd5.c
-index 4c85b7f..3e838cd 100644
---- a/crypt-sunmd5.c
-+++ b/crypt-sunmd5.c
-@@ -151,6 +151,11 @@ getrounds (const char *s)
- return ((uint32_t)val);
- }
-
-+#pragma GCC diagnostic push
-+#if defined(__GNUC__) && (__GNUC__ >= 8)
-+#pragma GCC diagnostic ignored "-Wformat-truncation"
-+#endif
-+
- void
- gensalt_sunmd5_rn (unsigned long count,
- const uint8_t *rbytes, size_t nrbytes,
-@@ -189,6 +194,7 @@ gensalt_sunmd5_rn (unsigned long count,
- "$" CRYPT_ALGNAME "," ROUNDS "%u$%s$",
- (unsigned int)count, rndstr);
- }
-+#pragma GCC diagnostic pop
-
- void
- crypt_sunmd5_rn (const char *phrase, const char *setting,
diff --git a/meta/recipes-core/libxcrypt/libxcrypt_4.0.0.bb b/meta/recipes-core/libxcrypt/libxcrypt_4.0.1.bb
index 8cc5edac49..6ed67a6761 100644
--- a/meta/recipes-core/libxcrypt/libxcrypt_4.0.0.bb
+++ b/meta/recipes-core/libxcrypt/libxcrypt_4.0.1.bb
@@ -9,11 +9,10 @@ LIC_FILES_CHKSUM ?= "file://LICENSING;md5=d1cc18f512ded3bd6000f3729f31be08 \
inherit autotools
-SRCREV ?= "215b32aa4e0b255c3356a96bd6d257661bad73ca"
+SRCREV ?= "089479bb24acd168613757a6f12d63caa95416b4"
SRCBRANCH ?= "master"
SRC_URI = "git://github.com/besser82/libxcrypt.git;branch=${SRCBRANCH} \
- file://0001-disable-format-truncation-warning-with-gcc-8.patch \
"
PROVIDES = "virtual/crypt"