aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/libxcrypt/libxcrypt_4.1.1.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-08-08 10:04:21 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-14 16:32:50 +0100
commit600b1f7da1bc308a52b566b77c994a90ed744b7e (patch)
treeeaa56417deaeba0379b833abe86d3f3ad5fa9ef8 /meta/recipes-core/libxcrypt/libxcrypt_4.1.1.bb
parente0ed7d74e61294a986f72a531b23f7e67922de29 (diff)
downloadopenembedded-core-contrib-600b1f7da1bc308a52b566b77c994a90ed744b7e.tar.gz
libxcrypt: Upgrade to 4.1.1
license update: Remove CDDL code with Public Domain pieces https://github.com/besser82/libxcrypt/commit/c76847e3be40c4ac0d78bc8518502418c6207144#diff-fdcb2380ff1eeea2e5795ec115ba1c0d inherit pkgconfig as it uses pkg-config during build Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/libxcrypt/libxcrypt_4.1.1.bb')
-rw-r--r--meta/recipes-core/libxcrypt/libxcrypt_4.1.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-core/libxcrypt/libxcrypt_4.1.1.bb b/meta/recipes-core/libxcrypt/libxcrypt_4.1.1.bb
new file mode 100644
index 0000000000..61ea22e4ea
--- /dev/null
+++ b/meta/recipes-core/libxcrypt/libxcrypt_4.1.1.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Extended cryptographic library (from glibc)"
+DESCRIPTION = "Forked code from glibc libary to extract only crypto part."
+HOMEPAGE = "https://github.com/besser82/libxcrypt"
+SECTION = "libs"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM ?= "file://LICENSING;md5=cb3ca4cabd2447a37bf186fad6f79852 \
+ file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
+"
+
+inherit autotools pkgconfig
+
+SRCREV ?= "21b455b68baad279e6a3936faced16c5e5634376"
+SRCBRANCH ?= "master"
+
+SRC_URI = "git://github.com/besser82/libxcrypt.git;branch=${SRCBRANCH} \
+ "
+
+PROVIDES = "virtual/crypt"
+
+FILES_${PN} = "${libdir}/libcrypt*.so.* ${libdir}/libcrypt-*.so ${libdir}/libowcrypt*.so.* ${libdir}/libowcrypt-*.so"
+
+S = "${WORKDIR}/git"
+
+BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE} -std=gnu99"
+TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}"
+
+BBCLASSEXTEND = "nativesdk"