aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/libcgroup/libcgroup_0.37.1.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-07-23 13:56:16 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-26 14:39:48 +0100
commit6ef8e6f2f9b0583fa0881e0dfc52462405b21ede (patch)
tree94192b30208a31f055a83e810c0503e17570b076 /meta/recipes-core/libcgroup/libcgroup_0.37.1.bb
parent823fab378bd46da6a296a67f981dffb31b1c8061 (diff)
downloadopenembedded-core-contrib-6ef8e6f2f9b0583fa0881e0dfc52462405b21ede.tar.gz
libcgroup_0.37.1.bb: Add recipe
This recipe is imported from meta-oe its a requirement for systemd to work. Now that systemd is living in a layer of its own. Lets have this recipe into core metadata Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/libcgroup/libcgroup_0.37.1.bb')
-rw-r--r--meta/recipes-core/libcgroup/libcgroup_0.37.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-core/libcgroup/libcgroup_0.37.1.bb b/meta/recipes-core/libcgroup/libcgroup_0.37.1.bb
new file mode 100644
index 0000000000..a99d7ac4c8
--- /dev/null
+++ b/meta/recipes-core/libcgroup/libcgroup_0.37.1.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Libcgroup"
+SECTION = "libs"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
+
+PR = "r1"
+
+inherit autotools pkgconfig
+
+DEPENDS = "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/project/libcg/${PN}/v${PV}/${PN}-${PV}.tar.bz2"
+SRC_URI[md5sum] = "24a41b18de112e8d085bb1f7d9e82af7"
+SRC_URI[sha256sum] = "0b08632de5d3641aa554b422d02a77d9367e57933328a8765204ad9588cd5c0d"
+
+EXTRA_OECONF = "${@base_contains('DISTRO_FEATURES', 'pam', '--enable-pam-module-dir=${base_libdir}/security --enable-pam=yes', '--enable-pam=no', d)}"
+
+# http://www.mail-archive.com/openembedded-devel@lists.openembedded.org/msg21444.html
+PARALLEL_MAKE = ""
+
+PACKAGES =+ "cgroups-pam-plugin"
+FILES_cgroups-pam-plugin = "${base_libdir}/security/pam_cgroup.so*"
+FILES_${PN}-dbg += "${base_libdir}/security/.debug"
+FILES_${PN}-dev += "${base_libdir}/security/*.la"
+
+# We really need the symlink so :(
+INSANE_SKIP_${PN} = "dev-so"