aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/initrdscripts/initramfs-live-boot_1.0.bb
diff options
context:
space:
mode:
authorBrian Lloyd <blloyd@familyhonor.net>2014-06-28 10:48:24 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-10 17:37:39 +0100
commit2be3b2607fd164d18498299dbfc020ff17dd2ca9 (patch)
tree80639ea1de4dd31136a673ed6c8d3aff07db16d7 /meta/recipes-core/initrdscripts/initramfs-live-boot_1.0.bb
parentf6eb8e4e44b66217e4ada9f830a058c5ba120932 (diff)
downloadopenembedded-core-contrib-2be3b2607fd164d18498299dbfc020ff17dd2ca9.tar.gz
Move boot media to /media/realroot for easy access after boot.
There are cases where software after boot may need to know the current boot disk. Under the current system, it is not guaranteed which disk is the boot. While /media/sda is a good guess, it isn't always right, nor is it a good assumption that only one boot disk is in the system. This gives a standard path to the original boot disk mount which can be used to, for instance, update the syslinux file on the boot media with a newer kernel, or updating the boot parameters to add user options for future boots. Knowing which disk is the boot media keeps from updating the non-boot disk when for instance multiple syslinux boot medias are plugged in (ie ensure correct syslinux is updated when the booted system is updated). Signed-off-by: Brian Lloyd <blloyd@familyhonor.net> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/initrdscripts/initramfs-live-boot_1.0.bb')
-rw-r--r--meta/recipes-core/initrdscripts/initramfs-live-boot_1.0.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-core/initrdscripts/initramfs-live-boot_1.0.bb b/meta/recipes-core/initrdscripts/initramfs-live-boot_1.0.bb
index 2d378e2101..ac54902415 100644
--- a/meta/recipes-core/initrdscripts/initramfs-live-boot_1.0.bb
+++ b/meta/recipes-core/initrdscripts/initramfs-live-boot_1.0.bb
@@ -5,7 +5,7 @@ DEPENDS = "virtual/kernel"
RDEPENDS_${PN} = "udev udev-extraconf"
SRC_URI = "file://init-live.sh"
-PR = "r11"
+PR = "r12"
do_install() {
install -m 0755 ${WORKDIR}/init-live.sh ${D}/init
@@ -13,5 +13,5 @@ do_install() {
FILES_${PN} += " /init "
-# Due to kernel depdendency
+# Due to kernel dependency
PACKAGE_ARCH = "${MACHINE_ARCH}"