aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/images
diff options
context:
space:
mode:
authorCalifornia Sullivan <california.l.sullivan@intel.com>2018-04-13 13:36:40 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-04-18 18:48:20 +0100
commit882ae0dcce2d96a7c286fc23b22b07972d3d8f93 (patch)
treea044374df220abe747f21a36e673ebf31eb25b90 /meta/recipes-core/images
parent2d955bb53a8ee36c0a648c23293139612f33f97b (diff)
downloadopenembedded-core-contrib-882ae0dcce2d96a7c286fc23b22b07972d3d8f93.tar.gz
core-image-minimal-initramfs: use initramfs-framework for initialization
initramfs-framework is more modular and expandable. This change was proposed in commit 28fc6ba761ed4a47efa7c43e7f7dff5e2fe72b5e "core-image-minimal-initramfs: use initramfs-framework by default" but reverted due to the selftests runqemu.RunqemuTests.test_boot_machine_iso and runqemu.RunqemuTests.test_boot_deploy_hddimg failing. Since then, the kinks have been worked out, and missing functionality that had been missed (non-EFI installation module) has been added. Since the PACKAGE_INSTALL variable was getting so long with all these individual modules getting added, I also introduced a new INITRAMFS_SCRIPTS variable to the core-image-minimal-initramfs recipe. This variable makes the recipe look much cleaner, and also allows easier replacement or additions to the scripts. Fixes [YOCTO #10987]. Signed-off-by: California Sullivan <california.l.sullivan@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-core/images')
-rw-r--r--meta/recipes-core/images/core-image-minimal-initramfs.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta/recipes-core/images/core-image-minimal-initramfs.bb b/meta/recipes-core/images/core-image-minimal-initramfs.bb
index c446e87bd1..6de860e43a 100644
--- a/meta/recipes-core/images/core-image-minimal-initramfs.bb
+++ b/meta/recipes-core/images/core-image-minimal-initramfs.bb
@@ -3,7 +3,15 @@ DESCRIPTION = "Small image capable of booting a device. The kernel includes \
the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \
first 'init' program more efficiently."
-PACKAGE_INSTALL = "initramfs-live-boot initramfs-live-install initramfs-live-install-efi ${VIRTUAL-RUNTIME_base-utils} udev base-passwd ${ROOTFS_BOOTSTRAP_INSTALL}"
+INITRAMFS_SCRIPTS ?= "\
+ initramfs-framework-base \
+ initramfs-module-setup-live \
+ initramfs-module-udev \
+ initramfs-module-install \
+ initramfs-module-install-efi \
+ "
+
+PACKAGE_INSTALL = "${INITRAMFS_SCRIPTS} ${VIRTUAL-RUNTIME_base-utils} udev base-passwd ${ROOTFS_BOOTSTRAP_INSTALL}"
# Do not pollute the initrd image with rootfs features
IMAGE_FEATURES = ""