summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/images/build-appliance-image_15.0.0.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-12-21 17:38:58 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-01-12 21:10:15 +0000
commit7ce1e88a3ad85bbb925bb9f7167dc0a5fd1c27f4 (patch)
treefd5aa428709789abf287ef9350fac7bcaa78a434 /meta/recipes-core/images/build-appliance-image_15.0.0.bb
parent4d4485442830bb52b152f0419f4ff9f1d581d46a (diff)
downloadopenembedded-core-contrib-7ce1e88a3ad85bbb925bb9f7167dc0a5fd1c27f4.tar.gz
classes: Only allow network in existing network accessing code
Use the newly added network task flag against tasks where network access is expected. This is do_fetch, do_checkuri, do_testimage, do_testsdk and do_testsdkext. We can't disable networking in sstate tasks due to sstate downloads and also so we can report hash equivalence to the server so network access is enabled in sstate tasks. Access within build-appliance do_image is also allowed due to the use of pip, this is a poor example made rather obvious now and needs to be reworked. Network access anywhere else in any other task isn't allowed. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/images/build-appliance-image_15.0.0.bb')
-rw-r--r--meta/recipes-core/images/build-appliance-image_15.0.0.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-core/images/build-appliance-image_15.0.0.bb b/meta/recipes-core/images/build-appliance-image_15.0.0.bb
index ce72a944e7..b774095b97 100644
--- a/meta/recipes-core/images/build-appliance-image_15.0.0.bb
+++ b/meta/recipes-core/images/build-appliance-image_15.0.0.bb
@@ -109,6 +109,8 @@ fakeroot do_populate_poky_src () {
}
IMAGE_PREPROCESS_COMMAND += "do_populate_poky_src; "
+# For pip usage above
+do_image[network] = "1"
addtask rootfs after do_unpack