summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/images/build-appliance-image_15.0.0.bb
diff options
context:
space:
mode:
authorTrevor Woerner <twoerner@gmail.com>2023-02-21 15:44:41 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-02-23 12:10:09 +0000
commita62b32907cb059b4512032f15571705540f1c147 (patch)
treeba129ab3c37812e5b63677d53cbdfe1af61531a3 /meta/recipes-core/images/build-appliance-image_15.0.0.bb
parent351f82b9918188eb4dbb6598733da5f5392fbd8f (diff)
downloadopenembedded-core-contrib-a62b32907cb059b4512032f15571705540f1c147.tar.gz
build-appliance-image: add /lib64 symlink
Add a /lib64 -> /lib symlink in case the build appliance is 64-bit. Building rust-native requires cargo to be run. The native cargo is linked to look for /lib64/ld-linux-x86-64.so.2 and can't be run without it. The build produces the following error, even though that file does exist: FileNotFoundError: [Errno 2] No such file or directory: '/home/builder/poky/build/tmp/work/x86_64-linux/rust-native/1.66.1-r0/rust-snapshot/bin/cargo' Trying to run this binary on its own gives: qemux86-64:~/poky/build$ tmp/work/x86_64-linux/rust-native/1.66.1-r0/rust-snapshot/bin/cargo -sh: tmp/work/x86_64-linux/rust-native/1.66.1-r0/rust-snapshot/bin/cargo: cannot execute: required file not found Signed-off-by: Trevor Woerner <twoerner@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/images/build-appliance-image_15.0.0.bb')
-rw-r--r--meta/recipes-core/images/build-appliance-image_15.0.0.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-core/images/build-appliance-image_15.0.0.bb b/meta/recipes-core/images/build-appliance-image_15.0.0.bb
index ce5af7764c..6e65922950 100644
--- a/meta/recipes-core/images/build-appliance-image_15.0.0.bb
+++ b/meta/recipes-core/images/build-appliance-image_15.0.0.bb
@@ -109,7 +109,13 @@ fakeroot do_populate_poky_src () {
chown -R builder:builder ${IMAGE_ROOTFS}/home/builder/.cache
}
-IMAGE_PREPROCESS_COMMAND += "do_populate_poky_src; "
+fakeroot do_tweak_image () {
+ # add a /lib64 symlink
+ # this is needed for building rust-native on a 64-bit build appliance
+ ln -rs ${IMAGE_ROOTFS}/lib ${IMAGE_ROOTFS}/lib64
+}
+
+IMAGE_PREPROCESS_COMMAND += "do_populate_poky_src; do_tweak_image; "
# For pip usage above
do_image[network] = "1"