aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2011-03-29 12:55:18 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-04-04 23:56:13 +0100
commit694db055f3729662e0e0193a31f2098be599877f (patch)
treeabb11942775e7eaa6c83be9448ca4ac4140196c1 /meta/recipes-core/glibc
parent917ac8c82a9e1e9df6029ecfa68e8f9ce2f8013c (diff)
downloadopenembedded-core-contrib-694db055f3729662e0e0193a31f2098be599877f.tar.gz
ldconfig-native-2.12.1: newer recipe with eglibc sources
This fixes [YOCTO #780] Handle the input/output data with different endian-ness correctly Also fix the definition of LD_SO for cross environment And remove the older 2.5 version of ldconfig-native recipe Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/recipes-core/glibc')
-rw-r--r--meta/recipes-core/glibc/ldconfig-native-2.5/32and64bit.patch289
-rw-r--r--meta/recipes-core/glibc/ldconfig-native-2.5/ldconfig-native-2.5.tar.bz2bin19454 -> 0 bytes
-rw-r--r--meta/recipes-core/glibc/ldconfig-native-2.5/ldconfig.patch460
-rw-r--r--meta/recipes-core/glibc/ldconfig-native_2.5.bb24
4 files changed, 0 insertions, 773 deletions
diff --git a/meta/recipes-core/glibc/ldconfig-native-2.5/32and64bit.patch b/meta/recipes-core/glibc/ldconfig-native-2.5/32and64bit.patch
deleted file mode 100644
index 4f8d3a39ca..0000000000
--- a/meta/recipes-core/glibc/ldconfig-native-2.5/32and64bit.patch
+++ /dev/null
@@ -1,289 +0,0 @@
-Index: ldconfig-native-2.5/readelflib.c
-===================================================================
---- ldconfig-native-2.5.orig/readelflib.c 2009-05-19 09:40:17.000000000 +0100
-+++ ldconfig-native-2.5/readelflib.c 2009-05-19 09:56:18.000000000 +0100
-@@ -40,38 +40,190 @@
-
- /* Returns 0 if everything is ok, != 0 in case of error. */
- int
--process_elf_file (const char *file_name, const char *lib, int *flag,
-+process_elf_file32 (const char *file_name, const char *lib, int *flag,
- unsigned int *osversion, char **soname, void *file_contents,
- size_t file_length)
- {
- int i;
- unsigned int j;
-- ElfW(Addr) loadaddr;
-+ Elf32_Addr loadaddr;
- unsigned int dynamic_addr;
- size_t dynamic_size;
- char *program_interpreter;
-
-- ElfW(Ehdr) *elf_header;
-- ElfW(Phdr) *elf_pheader, *segment;
-- ElfW(Dyn) *dynamic_segment, *dyn_entry;
-+ Elf32_Ehdr *elf_header;
-+ Elf32_Phdr *elf_pheader, *segment;
-+ Elf32_Dyn *dynamic_segment, *dyn_entry;
- char *dynamic_strings;
-
-- elf_header = (ElfW(Ehdr) *) file_contents;
-+ elf_header = (Elf32_Ehdr *) file_contents;
- *osversion = 0;
-
-- if (elf_header->e_ident [EI_CLASS] != ElfW (CLASS))
-+ if (elf_header->e_type != ET_DYN)
-+ {
-+ error (0, 0, _("%s is not a shared object file (Type: %d).\n"), file_name,
-+ elf_header->e_type);
-+ return 1;
-+ }
-+
-+ /* Get information from elf program header. */
-+ elf_pheader = (Elf32_Phdr *) (elf_header->e_phoff + file_contents);
-+ check_ptr (elf_pheader);
-+
-+ /* The library is an elf library, now search for soname and
-+ libc5/libc6. */
-+ *flag = FLAG_ELF;
-+
-+ loadaddr = -1;
-+ dynamic_addr = 0;
-+ dynamic_size = 0;
-+ program_interpreter = NULL;
-+ for (i = 0, segment = elf_pheader;
-+ i < elf_header->e_phnum; i++, segment++)
- {
-- if (opt_verbose)
-+ check_ptr (segment);
-+
-+ switch (segment->p_type)
- {
-- if (elf_header->e_ident [EI_CLASS] == ELFCLASS32)
-- error (0, 0, _("%s is a 32 bit ELF file.\n"), file_name);
-- else if (elf_header->e_ident [EI_CLASS] == ELFCLASS64)
-- error (0, 0, _("%s is a 64 bit ELF file.\n"), file_name);
-- else
-- error (0, 0, _("Unknown ELFCLASS in file %s.\n"), file_name);
-+ case PT_LOAD:
-+ if (loadaddr == (Elf32_Addr) -1)
-+ loadaddr = segment->p_vaddr - segment->p_offset;
-+ break;
-+
-+ case PT_DYNAMIC:
-+ if (dynamic_addr)
-+ error (0, 0, _("more than one dynamic segment\n"));
-+
-+ dynamic_addr = segment->p_offset;
-+ dynamic_size = segment->p_filesz;
-+ break;
-+
-+ case PT_INTERP:
-+ program_interpreter = (char *) (file_contents + segment->p_offset);
-+ check_ptr (program_interpreter);
-+
-+ /* Check if this is enough to classify the binary. */
-+ for (j = 0; j < sizeof (interpreters) / sizeof (interpreters [0]);
-+ ++j)
-+ if (strcmp (program_interpreter, interpreters[j].soname) == 0)
-+ {
-+ *flag = interpreters[j].flag;
-+ break;
-+ }
-+ break;
-+
-+ case PT_NOTE:
-+ if (!*osversion && segment->p_filesz == 32 && segment->p_align >= 4)
-+ {
-+ Elf32_Word *abi_note = (Elf32_Word *) (file_contents
-+ + segment->p_offset);
-+ if (abi_note [0] == 4 && abi_note [1] == 16 && abi_note [2] == 1
-+ && memcmp (abi_note + 3, "GNU", 4) == 0)
-+ *osversion = (abi_note [4] << 24) |
-+ ((abi_note [5] & 0xff) << 16) |
-+ ((abi_note [6] & 0xff) << 8) |
-+ (abi_note [7] & 0xff);
-+ }
-+ break;
-+
-+ default:
-+ break;
- }
-- return 1;
-+
- }
-+ if (loadaddr == (Elf32_Addr) -1)
-+ {
-+ /* Very strange. */
-+ loadaddr = 0;
-+ }
-+
-+ /* Now we can read the dynamic sections. */
-+ if (dynamic_size == 0)
-+ return 1;
-+
-+ dynamic_segment = (Elf32_Dyn *) (file_contents + dynamic_addr);
-+ check_ptr (dynamic_segment);
-+
-+ /* Find the string table. */
-+ dynamic_strings = NULL;
-+ for (dyn_entry = dynamic_segment; dyn_entry->d_tag != DT_NULL;
-+ ++dyn_entry)
-+ {
-+ check_ptr (dyn_entry);
-+ if (dyn_entry->d_tag == DT_STRTAB)
-+ {
-+ dynamic_strings = (char *) (file_contents + dyn_entry->d_un.d_val - loadaddr);
-+ check_ptr (dynamic_strings);
-+ break;
-+ }
-+ }
-+
-+ if (dynamic_strings == NULL)
-+ return 1;
-+
-+ /* Now read the DT_NEEDED and DT_SONAME entries. */
-+ for (dyn_entry = dynamic_segment; dyn_entry->d_tag != DT_NULL;
-+ ++dyn_entry)
-+ {
-+ if (dyn_entry->d_tag == DT_NEEDED || dyn_entry->d_tag == DT_SONAME)
-+ {
-+ char *name = dynamic_strings + dyn_entry->d_un.d_val;
-+ check_ptr (name);
-+
-+ if (dyn_entry->d_tag == DT_NEEDED)
-+ {
-+
-+ if (*flag == FLAG_ELF)
-+ {
-+ /* Check if this is enough to classify the binary. */
-+ for (j = 0;
-+ j < sizeof (known_libs) / sizeof (known_libs [0]);
-+ ++j)
-+ if (strcmp (name, known_libs [j].soname) == 0)
-+ {
-+ *flag = known_libs [j].flag;
-+ break;
-+ }
-+ }
-+ }
-+
-+ else if (dyn_entry->d_tag == DT_SONAME)
-+ *soname = xstrdup (name);
-+
-+ /* Do we have everything we need? */
-+ if (*soname && *flag != FLAG_ELF)
-+ return 0;
-+ }
-+ }
-+
-+ /* We reach this point only if the file doesn't contain a DT_SONAME
-+ or if we can't classify the library. If it doesn't have a
-+ soname, return the name of the library. */
-+ if (*soname == NULL)
-+ *soname = xstrdup (lib);
-+
-+ return 0;
-+}
-+
-+int
-+process_elf_file64 (const char *file_name, const char *lib, int *flag,
-+ unsigned int *osversion, char **soname, void *file_contents,
-+ size_t file_length)
-+{
-+ int i;
-+ unsigned int j;
-+ Elf64_Addr loadaddr;
-+ unsigned int dynamic_addr;
-+ size_t dynamic_size;
-+ char *program_interpreter;
-+
-+ Elf64_Ehdr *elf_header;
-+ Elf64_Phdr *elf_pheader, *segment;
-+ Elf64_Dyn *dynamic_segment, *dyn_entry;
-+ char *dynamic_strings;
-+
-+ elf_header = (Elf64_Ehdr *) file_contents;
-+ *osversion = 0;
-
- if (elf_header->e_type != ET_DYN)
- {
-@@ -81,7 +233,7 @@
- }
-
- /* Get information from elf program header. */
-- elf_pheader = (ElfW(Phdr) *) (elf_header->e_phoff + file_contents);
-+ elf_pheader = (Elf64_Phdr *) (elf_header->e_phoff + file_contents);
- check_ptr (elf_pheader);
-
- /* The library is an elf library, now search for soname and
-@@ -100,7 +252,7 @@
- switch (segment->p_type)
- {
- case PT_LOAD:
-- if (loadaddr == (ElfW(Addr)) -1)
-+ if (loadaddr == (Elf64_Addr) -1)
- loadaddr = segment->p_vaddr - segment->p_offset;
- break;
-
-@@ -129,7 +281,7 @@
- case PT_NOTE:
- if (!*osversion && segment->p_filesz == 32 && segment->p_align >= 4)
- {
-- ElfW(Word) *abi_note = (ElfW(Word) *) (file_contents
-+ Elf64_Word *abi_note = (Elf64_Word *) (file_contents
- + segment->p_offset);
- if (abi_note [0] == 4 && abi_note [1] == 16 && abi_note [2] == 1
- && memcmp (abi_note + 3, "GNU", 4) == 0)
-@@ -145,7 +297,7 @@
- }
-
- }
-- if (loadaddr == (ElfW(Addr)) -1)
-+ if (loadaddr == (Elf64_Addr) -1)
- {
- /* Very strange. */
- loadaddr = 0;
-@@ -155,7 +307,7 @@
- if (dynamic_size == 0)
- return 1;
-
-- dynamic_segment = (ElfW(Dyn) *) (file_contents + dynamic_addr);
-+ dynamic_segment = (Elf64_Dyn *) (file_contents + dynamic_addr);
- check_ptr (dynamic_segment);
-
- /* Find the string table. */
-@@ -218,3 +370,33 @@
-
- return 0;
- }
-+/* Returns 0 if everything is ok, != 0 in case of error. */
-+int
-+process_elf_file (const char *file_name, const char *lib, int *flag,
-+ unsigned int *osversion, char **soname, void *file_contents,
-+ size_t file_length)
-+{
-+ int i;
-+ unsigned int j;
-+ ElfW(Addr) loadaddr;
-+ unsigned int dynamic_addr;
-+ size_t dynamic_size;
-+ char *program_interpreter;
-+
-+ ElfW(Ehdr) *elf_header;
-+ ElfW(Phdr) *elf_pheader, *segment;
-+ ElfW(Dyn) *dynamic_segment, *dyn_entry;
-+ char *dynamic_strings;
-+
-+ elf_header = (ElfW(Ehdr) *) file_contents;
-+ *osversion = 0;
-+
-+ if (elf_header->e_ident [EI_CLASS] == ELFCLASS32)
-+ return process_elf_file32(file_name, lib,flag, osversion, soname, file_contents, file_length);
-+ else if (elf_header->e_ident [EI_CLASS] == ELFCLASS64)
-+ return process_elf_file64(file_name, lib,flag, osversion, soname, file_contents, file_length);
-+ error (0, 0, _("Unknown ELFCLASS in file %s.\n"), file_name);
-+ return 1;
-+}
-+
-+
diff --git a/meta/recipes-core/glibc/ldconfig-native-2.5/ldconfig-native-2.5.tar.bz2 b/meta/recipes-core/glibc/ldconfig-native-2.5/ldconfig-native-2.5.tar.bz2
deleted file mode 100644
index 693b35ced2..0000000000
--- a/meta/recipes-core/glibc/ldconfig-native-2.5/ldconfig-native-2.5.tar.bz2
+++ /dev/null
Binary files differ
diff --git a/meta/recipes-core/glibc/ldconfig-native-2.5/ldconfig.patch b/meta/recipes-core/glibc/ldconfig-native-2.5/ldconfig.patch
deleted file mode 100644
index d143a075f5..0000000000
--- a/meta/recipes-core/glibc/ldconfig-native-2.5/ldconfig.patch
+++ /dev/null
@@ -1,460 +0,0 @@
----
- cache.c | 11 +-
- chroot_canon.c | 7 +
- dl-cache.c | 235 ---------------------------------------------------------
- dl-cache.h | 3
- ldconfig.c | 27 ++++--
- readlib.c | 7 +
- xstrdup.c | 11 --
- 7 files changed, 45 insertions(+), 256 deletions(-)
-
-Index: 1/cache.c
-===================================================================
---- 1.orig/cache.c 2007-11-23 17:05:44.000000000 +0000
-+++ 1/cache.c 2007-11-23 17:05:56.000000000 +0000
-@@ -15,6 +15,9 @@
- along with this program; if not, write to the Free Software Foundation,
- Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. */
-
-+#define _LARGEFILE64_SOURCE
-+#define _GNU_SOURCE
-+
- #include <errno.h>
- #include <error.h>
- #include <dirent.h>
-@@ -29,8 +32,10 @@
- #include <sys/stat.h>
- #include <sys/types.h>
-
--#include <ldconfig.h>
--#include <dl-cache.h>
-+#include "ldconfig.h"
-+#include "dl-cache.h"
-+# define N_(msgid) msgid
-+#define _(msg) msg
-
- struct cache_entry
- {
-@@ -230,8 +235,6 @@ init_cache (void)
- entries = NULL;
- }
-
--
--
- static
- int compare (const struct cache_entry *e1, const struct cache_entry *e2)
- {
-Index: 1/chroot_canon.c
-===================================================================
---- 1.orig/chroot_canon.c 2007-11-23 17:05:44.000000000 +0000
-+++ 1/chroot_canon.c 2007-11-23 17:05:56.000000000 +0000
-@@ -16,6 +16,9 @@
- along with this program; if not, write to the Free Software Foundation,
- Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. */
-
-+#define _LARGEFILE64_SOURCE
-+#define _GNU_SOURCE
-+
- #include <stdlib.h>
- #include <string.h>
- #include <unistd.h>
-@@ -26,7 +29,9 @@
- #include <stddef.h>
- #include <stdint.h>
-
--#include <ldconfig.h>
-+#include "ldconfig.h"
-+
-+#define __set_errno(Val) errno = (Val)
-
- #ifndef PATH_MAX
- #define PATH_MAX 1024
-Index: 1/dl-cache.c
-===================================================================
---- 1.orig/dl-cache.c 2007-11-23 17:05:44.000000000 +0000
-+++ 1/dl-cache.c 2007-11-23 17:05:56.000000000 +0000
-@@ -19,12 +19,12 @@
-
- #include <assert.h>
- #include <unistd.h>
--#include <ldsodefs.h>
-+//#include "ldsodefs.h"
- #include <sys/mman.h>
- #include <dl-cache.h>
- #include <dl-procinfo.h>
-
--#include <stdio-common/_itoa.h>
-+//#include "_itoa.h"
-
- #ifndef _DL_PLATFORMS_COUNT
- # define _DL_PLATFORMS_COUNT 0
-@@ -38,103 +38,7 @@ static size_t cachesize;
- /* 1 if cache_data + PTR points into the cache. */
- #define _dl_cache_verify_ptr(ptr) (ptr < cache_data_size)
-
--#define SEARCH_CACHE(cache) \
--/* We use binary search since the table is sorted in the cache file. \
-- The first matching entry in the table is returned. \
-- It is important to use the same algorithm as used while generating \
-- the cache file. */ \
--do \
-- { \
-- left = 0; \
-- right = cache->nlibs - 1; \
-- \
-- while (left <= right) \
-- { \
-- __typeof__ (cache->libs[0].key) key; \
-- \
-- middle = (left + right) / 2; \
-- \
-- key = cache->libs[middle].key; \
-- \
-- /* Make sure string table indices are not bogus before using \
-- them. */ \
-- if (! _dl_cache_verify_ptr (key)) \
-- { \
-- cmpres = 1; \
-- break; \
-- } \
-- \
-- /* Actually compare the entry with the key. */ \
-- cmpres = _dl_cache_libcmp (name, cache_data + key); \
-- if (__builtin_expect (cmpres == 0, 0)) \
-- { \
-- /* Found it. LEFT now marks the last entry for which we \
-- know the name is correct. */ \
-- left = middle; \
-- \
-- /* There might be entries with this name before the one we \
-- found. So we have to find the beginning. */ \
-- while (middle > 0) \
-- { \
-- __typeof__ (cache->libs[0].key) key; \
-- \
-- key = cache->libs[middle - 1].key; \
-- /* Make sure string table indices are not bogus before \
-- using them. */ \
-- if (! _dl_cache_verify_ptr (key) \
-- /* Actually compare the entry. */ \
-- || _dl_cache_libcmp (name, cache_data + key) != 0) \
-- break; \
-- --middle; \
-- } \
-- \
-- do \
-- { \
-- int flags; \
-- __typeof__ (cache->libs[0]) *lib = &cache->libs[middle]; \
-- \
-- /* Only perform the name test if necessary. */ \
-- if (middle > left \
-- /* We haven't seen this string so far. Test whether the \
-- index is ok and whether the name matches. Otherwise \
-- we are done. */ \
-- && (! _dl_cache_verify_ptr (lib->key) \
-- || (_dl_cache_libcmp (name, cache_data + lib->key) \
-- != 0))) \
-- break; \
-- \
-- flags = lib->flags; \
-- if (_dl_cache_check_flags (flags) \
-- && _dl_cache_verify_ptr (lib->value)) \
-- { \
-- if (best == NULL || flags == GLRO(dl_correct_cache_id)) \
-- { \
-- HWCAP_CHECK; \
-- best = cache_data + lib->value; \
-- \
-- if (flags == GLRO(dl_correct_cache_id)) \
-- /* We've found an exact match for the shared \
-- object and no general `ELF' release. Stop \
-- searching. */ \
-- break; \
-- } \
-- } \
-- } \
-- while (++middle <= right); \
-- break; \
-- } \
-- \
-- if (cmpres < 0) \
-- left = middle + 1; \
-- else \
-- right = middle - 1; \
-- } \
-- } \
--while (0)
--
--
- int
--internal_function
- _dl_cache_libcmp (const char *p1, const char *p2)
- {
- while (*p1 != '\0')
-@@ -173,139 +77,4 @@ _dl_cache_libcmp (const char *p1, const
- }
-
-
--/* Look up NAME in ld.so.cache and return the file name stored there,
-- or null if none is found. */
-
--const char *
--internal_function
--_dl_load_cache_lookup (const char *name)
--{
-- int left, right, middle;
-- int cmpres;
-- const char *cache_data;
-- uint32_t cache_data_size;
-- const char *best;
--
-- /* Print a message if the loading of libs is traced. */
-- if (__builtin_expect (GLRO(dl_debug_mask) & DL_DEBUG_LIBS, 0))
-- _dl_debug_printf (" search cache=%s\n", LD_SO_CACHE);
--
-- if (cache == NULL)
-- {
-- /* Read the contents of the file. */
-- void *file = _dl_sysdep_read_whole_file (LD_SO_CACHE, &cachesize,
-- PROT_READ);
--
-- /* We can handle three different cache file formats here:
-- - the old libc5/glibc2.0/2.1 format
-- - the old format with the new format in it
-- - only the new format
-- The following checks if the cache contains any of these formats. */
-- if (file != MAP_FAILED && cachesize > sizeof *cache
-- && memcmp (file, CACHEMAGIC, sizeof CACHEMAGIC - 1) == 0)
-- {
-- size_t offset;
-- /* Looks ok. */
-- cache = file;
--
-- /* Check for new version. */
-- offset = ALIGN_CACHE (sizeof (struct cache_file)
-- + cache->nlibs * sizeof (struct file_entry));
--
-- cache_new = (struct cache_file_new *) ((void *) cache + offset);
-- if (cachesize < (offset + sizeof (struct cache_file_new))
-- || memcmp (cache_new->magic, CACHEMAGIC_VERSION_NEW,
-- sizeof CACHEMAGIC_VERSION_NEW - 1) != 0)
-- cache_new = (void *) -1;
-- }
-- else if (file != MAP_FAILED && cachesize > sizeof *cache_new
-- && memcmp (file, CACHEMAGIC_VERSION_NEW,
-- sizeof CACHEMAGIC_VERSION_NEW - 1) == 0)
-- {
-- cache_new = file;
-- cache = file;
-- }
-- else
-- {
-- if (file != MAP_FAILED)
-- __munmap (file, cachesize);
-- cache = (void *) -1;
-- }
--
-- assert (cache != NULL);
-- }
--
-- if (cache == (void *) -1)
-- /* Previously looked for the cache file and didn't find it. */
-- return NULL;
--
-- best = NULL;
--
-- if (cache_new != (void *) -1)
-- {
-- uint64_t platform;
--
-- /* This is where the strings start. */
-- cache_data = (const char *) cache_new;
--
-- /* Now we can compute how large the string table is. */
-- cache_data_size = (const char *) cache + cachesize - cache_data;
--
-- platform = _dl_string_platform (GLRO(dl_platform));
-- if (platform != (uint64_t) -1)
-- platform = 1ULL << platform;
--
-- /* Only accept hwcap if it's for the right platform. */
--#ifdef USE_TLS
--# define _DL_HWCAP_TLS_MASK (1LL << 63)
--#else
--# define _DL_HWCAP_TLS_MASK 0
--#endif
--#define HWCAP_CHECK \
-- if (GLRO(dl_osversion) && lib->osversion > GLRO(dl_osversion)) \
-- continue; \
-- if (_DL_PLATFORMS_COUNT \
-- && (lib->hwcap & _DL_HWCAP_PLATFORM) != 0 \
-- && (lib->hwcap & _DL_HWCAP_PLATFORM) != platform) \
-- continue; \
-- if (lib->hwcap \
-- & ~(GLRO(dl_hwcap) | _DL_HWCAP_PLATFORM | _DL_HWCAP_TLS_MASK)) \
-- continue
-- SEARCH_CACHE (cache_new);
-- }
-- else
-- {
-- /* This is where the strings start. */
-- cache_data = (const char *) &cache->libs[cache->nlibs];
--
-- /* Now we can compute how large the string table is. */
-- cache_data_size = (const char *) cache + cachesize - cache_data;
--
--#undef HWCAP_CHECK
--#define HWCAP_CHECK do {} while (0)
-- SEARCH_CACHE (cache);
-- }
--
-- /* Print our result if wanted. */
-- if (__builtin_expect (GLRO(dl_debug_mask) & DL_DEBUG_LIBS, 0)
-- && best != NULL)
-- _dl_debug_printf (" trying file=%s\n", best);
--
-- return best;
--}
--
--#ifndef MAP_COPY
--/* If the system does not support MAP_COPY we cannot leave the file open
-- all the time since this would create problems when the file is replaced.
-- Therefore we provide this function to close the file and open it again
-- once needed. */
--void
--_dl_unload_cache (void)
--{
-- if (cache != NULL && cache != (struct cache_file *) -1)
-- {
-- __munmap (cache, cachesize);
-- cache = NULL;
-- }
--}
--#endif
-Index: 1/dl-cache.h
-===================================================================
---- 1.orig/dl-cache.h 2007-11-23 17:05:44.000000000 +0000
-+++ 1/dl-cache.h 2007-11-23 17:05:56.000000000 +0000
-@@ -101,5 +101,4 @@ struct cache_file_new
- (((addr) + __alignof__ (struct cache_file_new) -1) \
- & (~(__alignof__ (struct cache_file_new) - 1)))
-
--extern int _dl_cache_libcmp (const char *p1, const char *p2)
-- internal_function;
-+extern int _dl_cache_libcmp (const char *p1, const char *p2);
-Index: 1/ldconfig.c
-===================================================================
---- 1.orig/ldconfig.c 2007-11-23 17:05:44.000000000 +0000
-+++ 1/ldconfig.c 2007-11-23 17:05:56.000000000 +0000
-@@ -15,6 +15,9 @@
- along with this program; if not, write to the Free Software Foundation,
- Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. */
-
-+#define _LARGEFILE64_SOURCE
-+#define _GNU_SOURCE
-+
- #define PROCINFO_CLASS static
- #include <alloca.h>
- #include <argp.h>
-@@ -37,10 +40,20 @@
- #include <glob.h>
- #include <libgen.h>
-
--#include <ldconfig.h>
--#include <dl-cache.h>
-+#include "ldconfig.h"
-+#include "dl-cache.h"
-+
-+#include "dl-procinfo.h"
-+
-+#include "argp.h"
-+
-+
-+#define SYSCONFDIR "/etc"
-+#define LIBDIR "/usr/lib"
-+#define SLIBDIR "/lib"
-+# define N_(msgid) msgid
-+#define _(msg) msg
-
--#include <dl-procinfo.h>
-
- #ifdef _DL_FIRST_PLATFORM
- # define _DL_FIRST_EXTRA (_DL_FIRST_PLATFORM + _DL_PLATFORMS_COUNT)
-@@ -53,7 +66,7 @@
- #endif
-
- /* Get libc version number. */
--#include <version.h>
-+#include "version.h"
-
- #define PACKAGE _libc_intl_domainname
-
-@@ -143,8 +156,8 @@ static const struct argp_option options[
- { NULL, 0, NULL, 0, NULL, 0 }
- };
-
--#define PROCINFO_CLASS static
--#include <dl-procinfo.c>
-+//#define PROCINFO_CLASS static
-+//#include <dl-procinfo.c>
-
- /* Short description of program. */
- static const char doc[] = N_("Configure Dynamic Linker Run Time Bindings.");
-@@ -281,7 +294,7 @@ parse_opt (int key, char *arg, struct ar
- static void
- print_version (FILE *stream, struct argp_state *state)
- {
-- fprintf (stream, "ldconfig (GNU %s) %s\n", PACKAGE, VERSION);
-+ fprintf (stream, "ldconfig (Hacked Poky Version)\n");
- fprintf (stream, gettext ("\
- Copyright (C) %s Free Software Foundation, Inc.\n\
- This is free software; see the source for copying conditions. There is NO\n\
-Index: 1/readlib.c
-===================================================================
---- 1.orig/readlib.c 2007-11-23 17:05:44.000000000 +0000
-+++ 1/readlib.c 2007-11-23 17:05:56.000000000 +0000
-@@ -21,6 +21,9 @@
- development version. Besides the simplification, it has also been
- modified to read some other file formats. */
-
-+#define _LARGEFILE64_SOURCE
-+#define _GNU_SOURCE
-+
- #include <a.out.h>
- #include <elf.h>
- #include <error.h>
-@@ -34,7 +37,9 @@
- #include <sys/stat.h>
- #include <gnu/lib-names.h>
-
--#include <ldconfig.h>
-+#include "ldconfig.h"
-+
-+#define _(msg) msg
-
- #define Elf32_CLASS ELFCLASS32
- #define Elf64_CLASS ELFCLASS64
-Index: 1/xstrdup.c
-===================================================================
---- 1.orig/xstrdup.c 2007-11-23 17:05:44.000000000 +0000
-+++ 1/xstrdup.c 2007-11-23 17:05:56.000000000 +0000
-@@ -15,15 +15,10 @@
- along with this program; if not, write to the Free Software Foundation,
- Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. */
-
--#ifdef HAVE_CONFIG_H
--# include <config.h>
--#endif
-+#define _GNU_SOURCE
-+
-+#include <string.h>
-
--#if defined STDC_HEADERS || defined HAVE_STRING_H || _LIBC
--# include <string.h>
--#else
--# include <strings.h>
--#endif
- void *xmalloc (size_t n) __THROW;
- char *xstrdup (char *string) __THROW;
-
diff --git a/meta/recipes-core/glibc/ldconfig-native_2.5.bb b/meta/recipes-core/glibc/ldconfig-native_2.5.bb
deleted file mode 100644
index 39c8ce35e5..0000000000
--- a/meta/recipes-core/glibc/ldconfig-native_2.5.bb
+++ /dev/null
@@ -1,24 +0,0 @@
-DESCRIPTION = "A standalone native ldconfig build"
-
-LICENSE = "GPLv2"
-
-LIC_FILES_CHKSUM = "file://${S}/ldconfig.c;endline=16;md5=8b3df71ec5b0feeeeab79025096aa92c"
-
-SRC_URI = "file://ldconfig-native-2.5.tar.bz2 \
- file://ldconfig.patch;patch=1 \
- file://32and64bit.patch;patch=1"
-
-PR = "r1"
-
-inherit native
-
-S = "${WORKDIR}/${PN}-${PV}"
-
-do_compile () {
- $CC ldconfig.c -std=gnu99 chroot_canon.c xmalloc.c xstrdup.c cache.c readlib.c -I. dl-cache.c -o ldconfig
-}
-
-do_install () {
- install -d ${D}/${bindir}/
- install ldconfig ${D}/${bindir}/
-}