aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-04-23 20:35:19 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-27 14:59:47 +0100
commit2bdbadd053a5e4f951a81f9094b6f8b99c4403d1 (patch)
tree74087e8e3937d7c0227bd074216f1d3e014e8052 /meta/recipes-core/glibc
parentf6a2628ffee10e43a37fba09106db5d47f7c4b93 (diff)
downloadopenembedded-core-contrib-2bdbadd053a5e4f951a81f9094b6f8b99c4403d1.tar.gz
glibc, packagegroup-self-hosted, packagegroup-core-lsb: Consider non-glibc libcs
Make skipping expression simpler to check for given libc Make sure glibc specific items are covered with right override Change-Id: I8b4a0b7cbfe38ffdc9320f798038c79c7220552b (From OE-Core rev: 6f4be55ca66b4470aa46c0ae356070ed166f44ce) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glibc')
-rw-r--r--meta/recipes-core/glibc/glibc_2.21.bb8
1 files changed, 3 insertions, 5 deletions
diff --git a/meta/recipes-core/glibc/glibc_2.21.bb b/meta/recipes-core/glibc/glibc_2.21.bb
index fcef4ff3e5..58a9601034 100644
--- a/meta/recipes-core/glibc/glibc_2.21.bb
+++ b/meta/recipes-core/glibc/glibc_2.21.bb
@@ -68,11 +68,9 @@ GLIBC_BROKEN_LOCALES = " _ER _ET so_ET yn_ER sid_ET tr_TR mn_MN gez_ET gez_ER bn
# this helps in easing out parsing for non-glibc system libraries
#
python __anonymous () {
- import re
- notglibc = (re.match('.*uclibc$', d.getVar('TARGET_OS', True)) != None) or (re.match('.*musl$', d.getVar('TARGET_OS', True)) != None)
- if notglibc:
- raise bb.parse.SkipPackage("incompatible with target %s" %
- d.getVar('TARGET_OS', True))
+ if d.getVar('TCLIBC', True) != "glibc":
+ raise bb.parse.SkipPackage("incompatible with %s C library" %
+ d.getVar('TCLIBC', True))
}
EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \