aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc/ldconfig-native_2.12.1.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2014-08-28 06:00:54 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-09-01 18:00:31 +0100
commit1027c535ea753e63d9ffe469a423e04467cf8940 (patch)
treecae4c0f7548f996a1f58d6a57806edfde475ff6e /meta/recipes-core/glibc/ldconfig-native_2.12.1.bb
parent750b2a89af404dc7b275aa40fb693b07b9b297fe (diff)
downloadopenembedded-core-contrib-1027c535ea753e63d9ffe469a423e04467cf8940.tar.gz
glibc: Migrate eglibc 2.19 -> glibc 2.20
- This is a big swoop change where we switch to using glibc - option-groups are forward ported - cross-localedef is extracted out from eglibc and hosted at github.com/kraj/localedef, its used for cross-localedef recipe - Other non ported patches from eglibc are forward ported ppc8xx cache line workaround SH fpcr values dynamic resolver installing PIC archives is there but is not applied libc header bootstrap - Delete eglibc recipes we moved back to using glibc now - Fix ppc/e500 build - Fix crypt module build when options are used - Fix fnmatch build when options OPTION_EGLIBC_LOCALE_CODE is unset HAVE_MBSTATE_T and HAVE_MBSRTOWCS should be defined conditionally based upon OPTION_EGLIBC_LOCALE_CODE being set/unset - Move the ports/ patches to relevant files now that ports is gone Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-core/glibc/ldconfig-native_2.12.1.bb')
-rw-r--r--meta/recipes-core/glibc/ldconfig-native_2.12.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-core/glibc/ldconfig-native_2.12.1.bb b/meta/recipes-core/glibc/ldconfig-native_2.12.1.bb
new file mode 100644
index 0000000000..7c3463589b
--- /dev/null
+++ b/meta/recipes-core/glibc/ldconfig-native_2.12.1.bb
@@ -0,0 +1,32 @@
+SUMMARY = "A standalone native ldconfig build"
+
+LICENSE = "GPLv2+"
+
+LIC_FILES_CHKSUM = "file://${S}/ldconfig.c;endline=17;md5=1d15f20937c055cb5de2329a4c054399"
+
+SRC_URI = "file://ldconfig-native-2.12.1.tar.bz2 \
+ file://ldconfig.patch \
+ file://ldconfig_aux-cache_path_fix.patch \
+ file://32and64bit.patch \
+ file://endian-ness_handling.patch \
+ file://flag_fix.patch \
+ file://endianess-header.patch \
+ file://ldconfig-default-to-all-multilib-dirs.patch \
+"
+
+PR = "r2"
+
+FILESEXTRAPATHS =. "${FILE_DIRNAME}/${P}:"
+
+inherit native
+
+S = "${WORKDIR}/${PN}-${PV}"
+
+do_compile () {
+ $CC ldconfig.c -std=gnu99 chroot_canon.c xmalloc.c xstrdup.c cache.c readlib.c -I. dl-cache.c -o ldconfig
+}
+
+do_install () {
+ install -d ${D}/${bindir}/
+ install ldconfig ${D}/${bindir}/
+}