summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glib-networking/glib-networking_2.64.3.bb
diff options
context:
space:
mode:
authorLee Chee Yang <chee.yang.lee@intel.com>2020-06-02 20:26:14 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-04 13:21:00 +0100
commit752310aaee91f017907bb4a7c0f4eaa1f41fda6e (patch)
treec18616532016b656d8deceeced0215fd782286f7 /meta/recipes-core/glib-networking/glib-networking_2.64.3.bb
parent4e5a55c7ecf7100bb87dcad31723ee27b7006ac2 (diff)
downloadopenembedded-core-contrib-752310aaee91f017907bb4a7c0f4eaa1f41fda6e.tar.gz
glib-networking: 2.64.2 -> 2.64.3
update to 2.64.3 which include fix for CVE-2020-13645, see: https://gitlab.gnome.org/GNOME/glib-networking/-/issues/135 Signed-off-by: Lee Chee Yang <chee.yang.lee@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glib-networking/glib-networking_2.64.3.bb')
-rw-r--r--meta/recipes-core/glib-networking/glib-networking_2.64.3.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-core/glib-networking/glib-networking_2.64.3.bb b/meta/recipes-core/glib-networking/glib-networking_2.64.3.bb
new file mode 100644
index 0000000000..a79e0e4988
--- /dev/null
+++ b/meta/recipes-core/glib-networking/glib-networking_2.64.3.bb
@@ -0,0 +1,34 @@
+SUMMARY = "GLib networking extensions"
+DESCRIPTION = "glib-networking contains the implementations of certain GLib networking features that cannot be implemented directly in GLib itself because of their dependencies."
+HOMEPAGE = "https://gitlab.gnome.org/GNOME/glib-networking/"
+BUGTRACKER = "http://bugzilla.gnome.org"
+
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+
+SECTION = "libs"
+DEPENDS = "glib-2.0"
+
+SRC_URI[archive.md5sum] = "eb382907ec941fe2fb1a9676b75acf7a"
+SRC_URI[archive.sha256sum] = "937a06b124052813bfc0b0b86bff42016ff01067582e1aca65bb6dbe0845a168"
+
+PACKAGECONFIG ??= "gnutls"
+
+PACKAGECONFIG[gnutls] = "-Dgnutls=enabled,-Dgnutls=disabled,gnutls"
+PACKAGECONFIG[openssl] = "-Dopenssl=enabled,-Dopenssl=disabled,openssl"
+PACKAGECONFIG[libproxy] = "-Dlibproxy=enabled,-Dlibproxy=disabled,libproxy"
+
+EXTRA_OEMESON = "-Dgnome_proxy=disabled"
+
+GNOMEBASEBUILDCLASS = "meson"
+inherit gnomebase gettext upstream-version-is-even gio-module-cache
+
+FILES_${PN} += "\
+ ${libdir}/gio/modules/libgio*.so \
+ ${datadir}/dbus-1/services/ \
+ ${systemd_user_unitdir} \
+ "
+FILES_${PN}-dev += "${libdir}/gio/modules/libgio*.la"
+FILES_${PN}-staticdev += "${libdir}/gio/modules/libgio*.a"
+
+BBCLASSEXTEND = "native"