summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glib-2.0
diff options
context:
space:
mode:
authorAlex Kiernan <alex.kiernan@gmail.com>2020-01-12 16:39:47 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-16 22:21:31 +0000
commit05c514bfdd0f3201f6a516c9dc93dff0592e23db (patch)
tree5f7683d7f32f22dc7076dfe08eb684ba07462816 /meta/recipes-core/glib-2.0
parentd826022100da5f84e668207b1631fd061accd50b (diff)
downloadopenembedded-core-contrib-05c514bfdd0f3201f6a516c9dc93dff0592e23db.tar.gz
glib-2.0: Fix hardcoded paths with dots in names
b4087338be09 ("glib-2.0: Fix hardcoded paths in checksums") fixed embedded paths in task hashes, but if these paths included dots then these were flattened when COREBASE was computed. Fix this by resolving our filenames before replacing the path segments with COREBASE. Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glib-2.0')
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0_2.62.4.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/glib-2.0/glib-2.0_2.62.4.bb b/meta/recipes-core/glib-2.0/glib-2.0_2.62.4.bb
index 5e71c81cca..e4cf50d22f 100644
--- a/meta/recipes-core/glib-2.0/glib-2.0_2.62.4.bb
+++ b/meta/recipes-core/glib-2.0/glib-2.0_2.62.4.bb
@@ -36,7 +36,7 @@ def find_meson_cross_files(d):
files = collections.OrderedDict()
for path in d.getVar("FILESPATH").split(":"):
for element in sitedata:
- filename = os.path.join(path, "meson.cross.d", element)
+ filename = os.path.normpath(os.path.join(path, "meson.cross.d", element))
files[filename.replace(corebase, "${COREBASE}")] = os.path.exists(filename)
items = ["--cross-file=" + k for k,v in files.items() if v]