aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glib-2.0/glib-2.0
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2011-11-18 12:59:48 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-18 12:25:46 +0000
commit812342e44e9e361a0fa93cfcfe65cf4dd6f2fb57 (patch)
tree1945cf6475d16fd7ffb9dd70d86835993998b3ab /meta/recipes-core/glib-2.0/glib-2.0
parent43adb8dcf4461b68a7ce0ba9d8acdb2012a70416 (diff)
downloadopenembedded-core-contrib-812342e44e9e361a0fa93cfcfe65cf4dd6f2fb57.tar.gz
glib-2.0: fix qsort_t testing for uclibc
* instead of disabling the configure test and set it always true use the site files to set it true for glibc/eglibc and false for uclibc * remove the patch ' tested only for uclibc * bump PR Signed-off-by: Henning Heinold <heinold@inf.fu-berlin.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glib-2.0/glib-2.0')
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0/remove.test.for.qsort_r.patch53
1 files changed, 0 insertions, 53 deletions
diff --git a/meta/recipes-core/glib-2.0/glib-2.0/remove.test.for.qsort_r.patch b/meta/recipes-core/glib-2.0/glib-2.0/remove.test.for.qsort_r.patch
deleted file mode 100644
index 5c0a07abb1..0000000000
--- a/meta/recipes-core/glib-2.0/glib-2.0/remove.test.for.qsort_r.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-while cross compiling we cannot execute run tests
-
-Upstream-Status: Inappropriate [configuration]
-
---- glib-2.30.0.orig/configure.ac 2011-09-29 16:57:35.000000000 +0200
-+++ glib-2.30.0/configure.ac 2011-09-29 17:00:19.931493488 +0200
-@@ -586,45 +586,7 @@
- dnl until we have checked this function is actually usable
- AC_CHECK_FUNC([qsort_r])
-
--# BSD has a qsort_r with wrong argument order
--if test x$ac_cv_func_qsort_r = xyes ; then
-- AC_CACHE_CHECK([if qsort_r uses glibc compatible argument order], glib_cv_have_qsort_r, [
-- AC_RUN_IFELSE([AC_LANG_SOURCE([[
-- #define _GNU_SOURCE
-- #include <stdlib.h>
--
-- static int
-- cmp (const void *a, const void *b, void *c)
-- {
-- const int *ia = a;
-- const int *ib = b;
--
-- if (*ia < *ib)
-- return -1;
-- else if (*ia > *ib)
-- return 1;
-- else
-- return 0;
-- }
--
-- int
-- main (int argc, char **argv)
-- {
-- int arr[3] = { 1, 2, 0 };
-- int d = 3;
--
-- qsort_r (arr, 3, sizeof (int), cmp, &d);
--
-- if (arr[0] == 0 && arr[1] == 1 && arr[2] == 2)
-- return 0;
-- else
-- return 1;
-- }]])],[glib_cv_have_qsort_r=yes],[glib_cv_have_qsort_r=no])])
--fi
--
--if test x$glib_cv_have_qsort_r = xyes ; then
-- AC_DEFINE(HAVE_QSORT_R, 1, [Define to 1 if you have the 'qsort_r' function])
--fi
-+AC_DEFINE(HAVE_QSORT_R, 1, [Define to 1 if you have the 'qsort_r' function])
-
- AC_CHECK_SIZEOF(char)
- AC_CHECK_SIZEOF(short)