aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/gettext/gettext-minimal-native_0.19.8.1.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-07-25 01:16:30 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-25 23:46:56 +0100
commit2b82c24a6b0148d1cc548605eab9be85f356ab6d (patch)
treefbb0954d7f57230357cbb431d386aba1a0b63694 /meta/recipes-core/gettext/gettext-minimal-native_0.19.8.1.bb
parent450f4597d491789b0680940218e0e0bee7104ada (diff)
downloadopenembedded-core-contrib-2b82c24a6b0148d1cc548605eab9be85f356ab6d.tar.gz
gettext-minimal-native: 0.19.4 -> 0.19.8.1
How to upgrade gettext-minimal-native: - Build gettext-native - Copy gettext-runtime/po/Makefile.in.in, build-aux/config.rpath and gettext-runtime/po/remove-potcdate.sin from gettext-native. - Update COPYING when needed (usually update the year), do not copy the whole COPYING file from gettext-native. - Go to gettext-native's ${S}/gettext-runtime/m4: > Remove lt*.m4 and libtool.m4 > copy lib-ld.m4 lib-link.m4 lib-prefix.m4 from ${S}/gettext-runtime/gnulib-m4/ > tar czvf /path/to/aclocal.tgz *.m4 Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/gettext/gettext-minimal-native_0.19.8.1.bb')
-rw-r--r--meta/recipes-core/gettext/gettext-minimal-native_0.19.8.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-core/gettext/gettext-minimal-native_0.19.8.1.bb b/meta/recipes-core/gettext/gettext-minimal-native_0.19.8.1.bb
new file mode 100644
index 0000000000..26ff19975d
--- /dev/null
+++ b/meta/recipes-core/gettext/gettext-minimal-native_0.19.8.1.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Minimal gettext for supporting native autoconf/automake"
+DESCRIPTION = "Contains the m4 macros sufficient to support building \
+autoconf/automake. This provides a significant build time speedup by \
+the removal of gettext-native from most dependency chains (now only \
+needed for gettext for the target)."
+SRC_URI = "file://aclocal.tgz \
+ file://config.rpath \
+ file://Makefile.in.in \
+ file://remove-potcdate.sin \
+ file://COPYING \
+ file://0001-PATCH-Disable-the-test-to-convert-euc-jp.patch \
+"
+
+INHIBIT_DEFAULT_DEPS = "1"
+INHIBIT_AUTOTOOLS_DEPS = "1"
+
+LICENSE = "FSF-Unlimited"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4bd090a20bfcd1a18f1f79837b5e3e91"
+
+inherit native
+
+S = "${WORKDIR}"
+
+do_install () {
+ install -d ${D}${datadir}/aclocal/
+ cp ${WORKDIR}/*.m4 ${D}${datadir}/aclocal/
+ install -d ${D}${datadir}/gettext/po/
+ cp ${WORKDIR}/config.rpath ${D}${datadir}/gettext/
+ cp ${WORKDIR}/Makefile.in.in ${D}${datadir}/gettext/po/
+ cp ${WORKDIR}/remove-potcdate.sin ${D}${datadir}/gettext/po/
+}