aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/expat/expat
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-14 11:06:33 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-16 00:01:44 +0100
commitda9ac8092497c3f2c246d3534f47e42cb2d9e4e8 (patch)
tree00f02d96bcfd265e0effc1c3133ee67527c83cf9 /meta/recipes-core/expat/expat
parent31ae16003cac6c8cf587c98d0c58e9f21690cb40 (diff)
downloadopenembedded-core-contrib-da9ac8092497c3f2c246d3534f47e42cb2d9e4e8.tar.gz
expat: Don't use getrandom() in the -native case
getrandom() is only available in glibc 2.25+ and uninative may relocate binaries onto systems that don't have this function. For now, force the code to the older codepath until we can come up with a better solution for this kind of issue. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/expat/expat')
-rw-r--r--meta/recipes-core/expat/expat/no_getrandom.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-core/expat/expat/no_getrandom.patch b/meta/recipes-core/expat/expat/no_getrandom.patch
new file mode 100644
index 0000000000..d64f1bf113
--- /dev/null
+++ b/meta/recipes-core/expat/expat/no_getrandom.patch
@@ -0,0 +1,23 @@
+The native version of expat may be used on older systems which dont have glibc 2.25
+and hence don't have getrandom() thanks to uninative. Disable the libc call and
+use the syscall instead to avoid a compatibility issue until we have 2.25 everywhere
+we support with uninative.
+
+RP
+2017/8/14
+
+Upstream-Status: Inappropriate
+
+Index: expat-2.2.3/configure.ac
+===================================================================
+--- expat-2.2.3.orig/configure.ac
++++ expat-2.2.3/configure.ac
+@@ -151,7 +151,7 @@ AC_LINK_IFELSE([AC_LANG_SOURCE([
+ #include <stdlib.h> /* for NULL */
+ #include <sys/random.h>
+ int main() {
+- return getrandom(NULL, 0U, 0U);
++ return getrandomBREAKME(NULL, 0U, 0U);
+ }
+ ])], [
+ AC_DEFINE([HAVE_GETRANDOM], [1],