aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2011-09-21 22:39:58 +0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-09-22 08:47:22 +0100
commit974cdb88680359aac5aefd11b84c4a374ab3a753 (patch)
tree745f04249c003f08cae1517365c8ea9d61d6adf3 /meta/recipes-core/eglibc
parentd12aa92b3dac1109d510e7b6f74055d1ab927817 (diff)
downloadopenembedded-core-contrib-974cdb88680359aac5aefd11b84c4a374ab3a753.tar.gz
eglibc: fix packaging of some of nativesdk packages
eglibc.inc contains packaging rules that depend on PKGSUFFIX expansion. However that variable wasn't expanded properly in some case. E.g. PACKAGES = " ... nscd${PKGSUFFIX} ..." FILES_nscd${PKGSUFFIX} = "${sbindir}/nscd*" would be expanded to PACKAGES = " ... nscd-nativesdk ..." FILES_nscd = "${sbindir}/nscd*" Thus leading to empty -nativesdk packages and missing files. To overcome that use python code blob to properly define PKGSUFFIX variable. Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/eglibc')
-rw-r--r--meta/recipes-core/eglibc/eglibc-locale.inc13
-rw-r--r--meta/recipes-core/eglibc/eglibc-package.inc9
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.12.bb2
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.13.bb2
4 files changed, 18 insertions, 8 deletions
diff --git a/meta/recipes-core/eglibc/eglibc-locale.inc b/meta/recipes-core/eglibc/eglibc-locale.inc
index 9424ff577a..cfc7d84eb9 100644
--- a/meta/recipes-core/eglibc/eglibc-locale.inc
+++ b/meta/recipes-core/eglibc/eglibc-locale.inc
@@ -26,10 +26,15 @@ BINARY_LOCALE_ARCHES ?= "arm.* i[3-6]86 x86_64 powerpc mips"
# set "0" for qemu emulation of native localedef for locale generation
LOCALE_GENERATION_WITH_CROSS-LOCALEDEF = "1"
-PR = "r16"
-
-PKGSUFFIX = ""
-PKGSUFFIX_virtclass-nativesdk = "-nativesdk"
+PR = "r17"
+
+python __anonymous () {
+ import bb
+ if bb.data.inherits_class("nativesdk", d):
+ bb.data.setVar("PKGSUFFIX", "-nativesdk", d)
+ else:
+ bb.data.setVar("PKGSUFFIX", "", d)
+}
PROVIDES = "virtual/libc-locale${PKGSUFFIX}"
diff --git a/meta/recipes-core/eglibc/eglibc-package.inc b/meta/recipes-core/eglibc/eglibc-package.inc
index 519a49c75f..dc6fce0442 100644
--- a/meta/recipes-core/eglibc/eglibc-package.inc
+++ b/meta/recipes-core/eglibc/eglibc-package.inc
@@ -17,8 +17,13 @@ python __anonymous () {
# Set this to zero if you don't want ldconfig in the output package
USE_LDCONFIG ?= "1"
-PKGSUFFIX = ""
-PKGSUFFIX_virtclass-nativesdk = "-nativesdk"
+python __anonymous () {
+ import bb
+ if bb.data.inherits_class("nativesdk", d):
+ bb.data.setVar("PKGSUFFIX", "-nativesdk", d)
+ else:
+ bb.data.setVar("PKGSUFFIX", "", d)
+}
PACKAGES = "${PN}-dbg ${PN} catchsegv${PKGSUFFIX} sln${PKGSUFFIX} nscd${PKGSUFFIX} ldd${PKGSUFFIX} ${PN}-utils eglibc-extra-nss${PKGSUFFIX} eglibc-thread-db${PKGSUFFIX} ${PN}-pic ${PN}-dev ${PN}-doc libcidn${PKGSUFFIX} libmemusage${PKGSUFFIX} libsegfault${PKGSUFFIX} ${PN}-pcprofile libsotruss${PKGSUFFIX}"
diff --git a/meta/recipes-core/eglibc/eglibc_2.12.bb b/meta/recipes-core/eglibc/eglibc_2.12.bb
index a9d208b756..7a1a5695fe 100644
--- a/meta/recipes-core/eglibc/eglibc_2.12.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.12.bb
@@ -1,7 +1,7 @@
require eglibc.inc
DEPENDS += "gperf-native"
-PR = "r24"
+PR = "r25"
SRCREV = "14158"
diff --git a/meta/recipes-core/eglibc/eglibc_2.13.bb b/meta/recipes-core/eglibc/eglibc_2.13.bb
index b549496c26..e172785c69 100644
--- a/meta/recipes-core/eglibc/eglibc_2.13.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.13.bb
@@ -3,7 +3,7 @@ require eglibc.inc
SRCREV = "14157"
DEPENDS += "gperf-native"
-PR = "r15"
+PR = "r16"
PR_append = "+svnr${SRCPV}"
EGLIBC_BRANCH="eglibc-2_13"