aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/dbus/dbus-test_1.6.18.bb
diff options
context:
space:
mode:
authorChong Lu <Chong.Lu@windriver.com>2014-04-08 11:30:56 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-04-25 17:15:50 +0100
commit0416583f014138656babdf78a574357ae5ff25bd (patch)
treebdca46b2d79336ff70d2f08621fee8f75d5f8762 /meta/recipes-core/dbus/dbus-test_1.6.18.bb
parentacfe3014d41de5e87cdbc58d0396349c6b9c3ffd (diff)
downloadopenembedded-core-contrib-0416583f014138656babdf78a574357ae5ff25bd.tar.gz
dbus: fix a hard dependency about dbus-ptest
If image contains dbus and ptest is in DISTRO_FEATURES, dbus-ptest package is installed, regardless of whether ptest-pkgs is in IMAGE_FEATURES. This issue will increase size for most small images. This patch fixes this problem. [YOCTO #5702] Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/dbus/dbus-test_1.6.18.bb')
-rw-r--r--meta/recipes-core/dbus/dbus-test_1.6.18.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-core/dbus/dbus-test_1.6.18.bb b/meta/recipes-core/dbus/dbus-test_1.6.18.bb
new file mode 100644
index 0000000000..9ea0f4d374
--- /dev/null
+++ b/meta/recipes-core/dbus/dbus-test_1.6.18.bb
@@ -0,0 +1,53 @@
+SUMMARY = "D-Bus test package (for D-bus functionality testing only)"
+HOMEPAGE = "http://dbus.freedesktop.org"
+SECTION = "base"
+LICENSE = "AFL-2 | GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=10dded3b58148f3f1fd804b26354af3e \
+ file://dbus/dbus.h;beginline=6;endline=20;md5=7755c9d7abccd5dbd25a6a974538bb3c"
+
+DEPENDS = "python-pygobject dbus dbus-glib"
+
+RDEPENDS_${PN} += "make"
+RDEPENDS_${PN}-dev = ""
+
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
+ file://tmpdir.patch \
+ file://ptest.patch \
+ file://dbus-1.init \
+ file://run-ptest \
+ file://python-config.patch \
+ file://clear-guid_from_server-if-send_negotiate_unix_f.patch \
+ "
+
+SRC_URI[md5sum] = "b02e9c95027a416987b81f9893831061"
+SRC_URI[sha256sum] = "7085a0895a9eb11a952394cdbea6d8b4358e17cb991fed0e8fb85e2b9e686dcd"
+
+S="${WORKDIR}/dbus-${PV}"
+FILESPATH = "${FILE_DIRNAME}/dbus"
+
+inherit autotools pkgconfig gettext ptest
+
+EXTRA_OECONF_X = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '--with-x', '--without-x', d)}"
+EXTRA_OECONF_X_class-native = "--without-x"
+
+EXTRA_OECONF = "--enable-tests \
+ --enable-modular-tests \
+ --enable-installed-tests \
+ --enable-checks \
+ --enable-asserts \
+ --enable-verbose-mode \
+ --disable-xml-docs \
+ --disable-doxygen-docs \
+ --disable-libaudit \
+ --with-xml=expat \
+ --disable-systemd \
+ --without-systemdsystemunitdir \
+ --with-dbus-test-dir=${PTEST_PATH} \
+ ${EXTRA_OECONF_X}"
+
+do_install() {
+}
+
+do_install_ptest() {
+ find ${D}${PTEST_PATH} -name Makefile | xargs sed -i 's/^Makefile:/_Makefile:/'
+}