aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/coreutils
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2012-12-12 18:31:36 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-13 15:18:46 +0000
commit71594f81b8c6a3ecc8f0d738cb7952e4c7b92d69 (patch)
tree5a57810279679269e2231e0b7b6435960b746fc2 /meta/recipes-core/coreutils
parent1f476dbb22197f3378b727675c1a8109ecf14249 (diff)
downloadopenembedded-core-contrib-71594f81b8c6a3ecc8f0d738cb7952e4c7b92d69.tar.gz
coreutils_6.9: Update the older coreutils to no longer provide 'su'
'su' was removed from newer versions of coreutils, and in OE-Core we pick up 'su' from shadow instead. So simply remove the binary from the install image to match expected behavior and avoid failures due to conflicting 'su' binaries during do_rootfs when building non-GPLv3 images. (From OE-Core rev: b4c5fc7c025ff864280be9678e6dd856971c71d7) Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/coreutils')
-rw-r--r--meta/recipes-core/coreutils/coreutils_6.9.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-core/coreutils/coreutils_6.9.bb b/meta/recipes-core/coreutils/coreutils_6.9.bb
index 1b25320628..37d8dc9d51 100644
--- a/meta/recipes-core/coreutils/coreutils_6.9.bb
+++ b/meta/recipes-core/coreutils/coreutils_6.9.bb
@@ -8,7 +8,7 @@ BUGTRACKER = "http://debbugs.gnu.org/coreutils"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
file://src/ls.c;beginline=4;endline=16;md5=15ed60f67b1db5fedd5dbc37cf8a9543"
-PR = "r3"
+PR = "r4"
DEPENDS = "coreutils-native-${PV}"
DEPENDS_class-native = "gettext-native"
@@ -60,6 +60,10 @@ do_install() {
# in update-alternatives to fail, therefore use lbracket - the name used
# for the actual source file.
mv ${D}${bindir}/[ ${D}${bindir}/lbracket.${BPN}
+
+ # Newer versions of coreutils do not include su, to mimic this behavior
+ # we simply remove it.
+ rm -f ${D}${bindir}/su
}
inherit update-alternatives