aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/coreutils
diff options
context:
space:
mode:
authorDengke Du <dengke.du@windriver.com>2016-03-15 22:49:13 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-03-25 10:29:15 +0000
commit5b70c7e1290f7d29c07617ae1eb0285e94c805d4 (patch)
tree6a1bdac26888cc7afbc518163ec8c5d5f7996289 /meta/recipes-core/coreutils
parentb47c53b70e60990ac83ab488b30fd962e735a4f8 (diff)
downloadopenembedded-core-contrib-5b70c7e1290f7d29c07617ae1eb0285e94c805d4.tar.gz
nativesdk-coreutils: a lot of warnings fixed
When we create nativesdk-coreutils, a lot of warnings appear,it show many files can't find. Because in the coreutils recipe, it didn't contain the do_install for the nativesdk, so when the alternative system check the files in the following process, it can't find the files. So we should add the do_install for the nativesdk, change the function do_install_append_class-target() to do_install_append() in the file: meta/recipes-core/coreutils/coreutils_8.25.bb in this way, the alternative system can find the files, the warnings disappear. (From OE-Core rev: 37039da6a09d7781beb93892932488940786b41f) Signed-off-by: Dengke Du <dengke.du@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/coreutils')
-rw-r--r--meta/recipes-core/coreutils/coreutils_8.25.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-core/coreutils/coreutils_8.25.bb b/meta/recipes-core/coreutils/coreutils_8.25.bb
index b875b18f9c..419a693372 100644
--- a/meta/recipes-core/coreutils/coreutils_8.25.bb
+++ b/meta/recipes-core/coreutils/coreutils_8.25.bb
@@ -28,6 +28,7 @@ SRC_URI[manpages.sha256sum] = "2ee31c3a6d2276f49c5515375d4a0c1047580da6ac1053689
EXTRA_OECONF_class-native = "--without-gmp"
EXTRA_OECONF_class-target = "--enable-install-program=arch --libexecdir=${libdir}"
+EXTRA_OECONF_class-nativesdk = "--enable-install-program=arch"
# acl and xattr are not default features
#
@@ -68,7 +69,7 @@ do_compile_prepend () {
mkdir -p ${B}/src
}
-do_install_append_class-target() {
+do_install_append() {
for i in df mktemp base64; do mv ${D}${bindir}/$i ${D}${bindir}/$i.${BPN}; done
install -d ${D}${base_bindir}