aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/console-tools
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2012-04-16 12:44:41 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-24 15:51:33 +0100
commit9c2aa2da7cb9ceec02c5d42d18a623a51f922cea (patch)
treef5a01ae418f96a64ee76439bea3a46100db0a793 /meta/recipes-core/console-tools
parent728569a3db005a935e6b08d6aac3e23e88d486df (diff)
downloadopenembedded-core-contrib-9c2aa2da7cb9ceec02c5d42d18a623a51f922cea.tar.gz
console-tools: Use update-alternatives
Use update-alternatives and sync to the way the replace kbd package does things. Using update-alternatives ensures that the proper provides are setup in the packages. Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Diffstat (limited to 'meta/recipes-core/console-tools')
-rw-r--r--meta/recipes-core/console-tools/console-tools_0.3.2.bb27
1 files changed, 5 insertions, 22 deletions
diff --git a/meta/recipes-core/console-tools/console-tools_0.3.2.bb b/meta/recipes-core/console-tools/console-tools_0.3.2.bb
index 5f1d640a2d..6027d4abd1 100644
--- a/meta/recipes-core/console-tools/console-tools_0.3.2.bb
+++ b/meta/recipes-core/console-tools/console-tools_0.3.2.bb
@@ -3,7 +3,7 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING.kbd;md5=9b2d91511d3d80d4d20ac6e6b0137fe9"
SUMMARY = "Allows you to set-up and manipulate the Linux console."
DESCRIPTION = "Provides tools that enable the set-up and manipulation of the linux console and console-font files."
-PR = "r4"
+PR = "r5"
SRC_URI = "${SOURCEFORGE_MIRROR}/lct/console-tools-${PV}.tar.gz \
file://codepage.patch \
@@ -30,28 +30,11 @@ do_compile () {
oe_runmake 'SUBDIRS=${SUBDIRS}'
}
-inherit autotools gettext
+inherit autotools gettext update-alternatives
-do_install () {
- autotools_do_install
- mv ${D}${bindir}/chvt ${D}${bindir}/chvt.${PN}
- mv ${D}${bindir}/deallocvt ${D}${bindir}/deallocvt.${PN}
- mv ${D}${bindir}/openvt ${D}${bindir}/openvt.${PN}
- mv ${D}${bindir}/fgconsole ${D}${bindir}/fgconsole.${PN}
-}
-
-pkg_postinst_${PN} () {
- update-alternatives --install ${bindir}/chvt chvt chvt.${PN} 100
- update-alternatives --install ${bindir}/deallocvt deallocvt deallocvt.${PN} 100
- update-alternatives --install ${bindir}/openvt openvt openvt.${PN} 100
- update-alternatives --install ${bindir}/fgconsole fgconsole fgconsole.${PN} 100
-}
+ALTERNATIVE_PRIORITY = "100"
-pkg_prerm_${PN} () {
- update-alternatives --remove chvt chvt.${PN}
- update-alternatives --remove deallocvt deallocvt.${PN}
- update-alternatives --remove openvt openvt.${PN}
- update-alternatives --remove fgconsole fgconsole.${PN}
-}
+bindir_progs = "chvt deallocvt fgconsole openvt"
+ALTERNATIVE_LINKS = "${bindir}/${@' ${bindir}/'.join((d.getVar('bindir_progs', True)).split())}"
RDEPENDS_${PN} = "bash"