aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/busybox
diff options
context:
space:
mode:
authorMing Liu <ming.liu@windriver.com>2014-01-09 17:57:07 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-10 15:11:33 +0000
commit21ba0297409bfc6e0fb89f45c9bfed8981c7df5b (patch)
tree709072ddd123492ac64feec0879ee369cee5e4bd /meta/recipes-core/busybox
parentd28eba07553020bf9bfb1419663c1d18ab36ab66 (diff)
downloadopenembedded-core-contrib-21ba0297409bfc6e0fb89f45c9bfed8981c7df5b.tar.gz
busybox: lineedit: initialize delptr
In vi mode, the 'p' and 'P' commands caused a segfault when nothing had been put in the buffer yet because the delptr was not initialized. Signed-off-by: Ming Liu <ming.liu@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/busybox')
-rw-r--r--meta/recipes-core/busybox/busybox/busybox-lineedit-initialize-delptr.patch23
-rw-r--r--meta/recipes-core/busybox/busybox_1.21.1.bb1
2 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-core/busybox/busybox/busybox-lineedit-initialize-delptr.patch b/meta/recipes-core/busybox/busybox/busybox-lineedit-initialize-delptr.patch
new file mode 100644
index 0000000000..e59211bd5d
--- /dev/null
+++ b/meta/recipes-core/busybox/busybox/busybox-lineedit-initialize-delptr.patch
@@ -0,0 +1,23 @@
+Derived from:
+http://git.busybox.net/busybox/commit/?id=46031da862a60422f80050a905cea0b67026b021.
+
+In vi mode, the 'p' and 'P' commands caused a segfault when nothing had
+been put in the buffer yet because the delptr was not initialized.
+
+Upstream-Status: Backport
+
+Signed-off-by: Shawn J. Goff <shawn7400@gmail.com>
+Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
+Signed-off-by: Ming Liu <ming.liu@windriver.com>
+
+diff -urpN a/libbb/lineedit.c b/libbb/lineedit.c
+--- a/libbb/lineedit.c
++++ b/libbb/lineedit.c
+@@ -187,6 +187,7 @@ extern struct lineedit_statics *const li
+ cmdedit_termw = 80; \
+ IF_FEATURE_EDITING_FANCY_PROMPT(num_ok_lines = 1;) \
+ IF_USERNAME_OR_HOMEDIR(home_pwd_buf = (char*)null_str;) \
++ IF_FEATURE_EDITING_VI(delptr = delbuf;) \
+ } while (0)
+
+ static void deinit_S(void)
diff --git a/meta/recipes-core/busybox/busybox_1.21.1.bb b/meta/recipes-core/busybox/busybox_1.21.1.bb
index 267604afa3..cf59f58e76 100644
--- a/meta/recipes-core/busybox/busybox_1.21.1.bb
+++ b/meta/recipes-core/busybox/busybox_1.21.1.bb
@@ -35,6 +35,7 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
file://busybox-list-suid-and-non-suid-app-configs.patch \
file://busybox-sed-fix-sed-clusternewline-testcase.patch \
file://find-get-rid-of-nested-functions.patch \
+ file://busybox-lineedit-initialize-delptr.patch \
"
SRC_URI[tarball.md5sum] = "795394f83903b5eec6567d51eebb417e"