summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/busybox
diff options
context:
space:
mode:
authorMikko Rapeli <mikko.rapeli@bmw.de>2019-07-17 12:08:36 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-07-18 12:16:19 +0100
commitaab3b7511cf78d9e1db8e4c0f88793a0d3a959bd (patch)
treeca98d5fe2b944146869b097d9f88c65a275b6e3d /meta/recipes-core/busybox
parentab7dd20beec73069d7380142f6ea467fd457dba8 (diff)
downloadopenembedded-core-contrib-aab3b7511cf78d9e1db8e4c0f88793a0d3a959bd.tar.gz
busybox: enable unicode support
While creating and deleting files with unicode or other encodings works, it's annoying when ls and other core utils show questionmarks instead of the unicode characters. In 2019, it's quite common that users of embedded devices based on yocto need unicode support. Debugging a box with unicode encoded file names is a bit annoying when core utils from busybox don't support them. The unicode config fragment has the same config as Debian in their deb and udeb builds of version 1:1.30.1-4. If developers do not want this or other default yocto features in busybox, or optimize the configuration for size, then they likely run a completely custom configuration. Thus I think it's safe to enable unicode support by default. (From OE-Core rev: a48438422dbe64095bdb379c20428ba87e2a0e99) Signed-off-by: Mikko Rapeli <mikko.rapeli@bmw.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/busybox')
-rw-r--r--meta/recipes-core/busybox/busybox/unicode.cfg10
-rw-r--r--meta/recipes-core/busybox/busybox_1.31.0.bb1
2 files changed, 11 insertions, 0 deletions
diff --git a/meta/recipes-core/busybox/busybox/unicode.cfg b/meta/recipes-core/busybox/busybox/unicode.cfg
new file mode 100644
index 0000000000..ecb5a64f27
--- /dev/null
+++ b/meta/recipes-core/busybox/busybox/unicode.cfg
@@ -0,0 +1,10 @@
+CONFIG_UNICODE_SUPPORT=y
+# CONFIG_UNICODE_USING_LOCALE is not set
+CONFIG_FEATURE_CHECK_UNICODE_IN_ENV=y
+CONFIG_SUBST_WCHAR=63
+CONFIG_LAST_SUPPORTED_WCHAR=767
+CONFIG_UNICODE_COMBINING_WCHARS=y
+CONFIG_UNICODE_WIDE_WCHARS=y
+# CONFIG_UNICODE_BIDI_SUPPORT is not set
+# CONFIG_UNICODE_NEUTRAL_TABLE is not set
+# CONFIG_UNICODE_PRESERVE_BROKEN is not set
diff --git a/meta/recipes-core/busybox/busybox_1.31.0.bb b/meta/recipes-core/busybox/busybox_1.31.0.bb
index f0185434aa..c1da372629 100644
--- a/meta/recipes-core/busybox/busybox_1.31.0.bb
+++ b/meta/recipes-core/busybox/busybox_1.31.0.bb
@@ -37,6 +37,7 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
${@["", "file://init.cfg"][(d.getVar('VIRTUAL-RUNTIME_init_manager') == 'busybox')]} \
${@["", "file://mdev.cfg"][(d.getVar('VIRTUAL-RUNTIME_dev_manager') == 'busybox-mdev')]} \
file://syslog.cfg \
+ file://unicode.cfg \
file://inittab \
file://rcS \
file://rcK \