aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/busybox
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2015-10-05 14:55:51 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-01 21:31:01 +0000
commitaeeb80be6db8df0548c97b4a40c1561cc724debb (patch)
treeef6836de5fcf4a1134daa9fa4209c56f26e55dc7 /meta/recipes-core/busybox
parent61e1617f9f024ead0b77004c94f2de45c88a4aa8 (diff)
downloadopenembedded-core-contrib-aeeb80be6db8df0548c97b4a40c1561cc724debb.tar.gz
busybox: move EXTRA_OEMAKE etc into busybox.inc
EXTRA_OEMAKE options and do_install_ptest() are common to both busybox recipes, so move into busybox.inc. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-core/busybox')
-rw-r--r--meta/recipes-core/busybox/busybox.inc8
-rw-r--r--meta/recipes-core/busybox/busybox_1.23.2.bb8
-rw-r--r--meta/recipes-core/busybox/busybox_git.bb8
3 files changed, 7 insertions, 17 deletions
diff --git a/meta/recipes-core/busybox/busybox.inc b/meta/recipes-core/busybox/busybox.inc
index 9e1a207e6d..ac534a4acb 100644
--- a/meta/recipes-core/busybox/busybox.inc
+++ b/meta/recipes-core/busybox/busybox.inc
@@ -18,7 +18,7 @@ BUSYBOX_SPLIT_SUID ?= "1"
export EXTRA_CFLAGS = "${CFLAGS}"
export EXTRA_LDFLAGS = "${LDFLAGS}"
-EXTRA_OEMAKE += "LD='${CCLD}'"
+EXTRA_OEMAKE += "LD='${CCLD}' V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX} SKIP_STRIP=y"
PACKAGES =+ "${PN}-httpd ${PN}-udhcpd ${PN}-udhcpc ${PN}-syslog ${PN}-mdev ${PN}-hwclock"
@@ -301,6 +301,12 @@ do_install () {
fi
}
+do_install_ptest () {
+ cp -r ${B}/testsuite ${D}${PTEST_PATH}/
+ cp ${B}/.config ${D}${PTEST_PATH}/
+ ln -s /bin/busybox ${D}${PTEST_PATH}/busybox
+}
+
inherit update-alternatives
ALTERNATIVE_PRIORITY = "50"
diff --git a/meta/recipes-core/busybox/busybox_1.23.2.bb b/meta/recipes-core/busybox/busybox_1.23.2.bb
index 25598232ae..e9f7eb60b5 100644
--- a/meta/recipes-core/busybox/busybox_1.23.2.bb
+++ b/meta/recipes-core/busybox/busybox_1.23.2.bb
@@ -43,11 +43,3 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
SRC_URI[tarball.md5sum] = "7925683d7dd105aabe9b6b618d48cc73"
SRC_URI[tarball.sha256sum] = "05a6f9e21aad8c098e388ae77de7b2361941afa7157ef74216703395b14e319a"
-
-EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX} SKIP_STRIP=y"
-
-do_install_ptest () {
- cp -r ${B}/testsuite ${D}${PTEST_PATH}/
- cp ${B}/.config ${D}${PTEST_PATH}/
- ln -s /bin/busybox ${D}${PTEST_PATH}/busybox
-}
diff --git a/meta/recipes-core/busybox/busybox_git.bb b/meta/recipes-core/busybox/busybox_git.bb
index ed1c0a84bd..e9ff0bc41e 100644
--- a/meta/recipes-core/busybox/busybox_git.bb
+++ b/meta/recipes-core/busybox/busybox_git.bb
@@ -44,12 +44,4 @@ SRC_URI = "git://busybox.net/busybox.git \
file://getopts.cfg \
"
-EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX} SKIP_STRIP=y"
-
-do_install_ptest () {
- cp -r ${B}/testsuite ${D}${PTEST_PATH}/
- cp ${B}/.config ${D}${PTEST_PATH}/
- ln -s /bin/busybox ${D}${PTEST_PATH}/busybox
-}
-
DEFAULT_PREFERENCE = "-1"