summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/busybox
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2019-04-17 11:18:51 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-04-23 23:30:10 +0100
commit7880a7102dea7ab928790d3f571f293ea993af2d (patch)
tree63623c1cb271bf31657d73b61f8d8850bbdcde27 /meta/recipes-core/busybox
parent890a460d2ad9bce8f6a1df055e040f334f958673 (diff)
downloadopenembedded-core-contrib-7880a7102dea7ab928790d3f571f293ea993af2d.tar.gz
busybox: fix ptest failure about 'dc'
Fix the following two failure of busybox ptest: FAIL: dc read FAIL: dc read string These two test cases relies on the functionalities enabled by CONFIG_FEATURE_DC_BIG. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/busybox')
-rw-r--r--meta/recipes-core/busybox/busybox/0001-dc.tests-fix-two-test-case-to-also-depend-on-DC_BIG.patch39
-rw-r--r--meta/recipes-core/busybox/busybox_1.30.1.bb1
2 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-core/busybox/busybox/0001-dc.tests-fix-two-test-case-to-also-depend-on-DC_BIG.patch b/meta/recipes-core/busybox/busybox/0001-dc.tests-fix-two-test-case-to-also-depend-on-DC_BIG.patch
new file mode 100644
index 0000000000..d22db4a663
--- /dev/null
+++ b/meta/recipes-core/busybox/busybox/0001-dc.tests-fix-two-test-case-to-also-depend-on-DC_BIG.patch
@@ -0,0 +1,39 @@
+From a4e03fbb4d82f91069d96005405f89c45b8fd157 Mon Sep 17 00:00:00 2001
+From: Chen Qi <Qi.Chen@windriver.com>
+Date: Wed, 17 Apr 2019 09:24:37 +0800
+Subject: [PATCH] dc.tests: fix two test case to also depend on DC_BIG
+
+Upstream-Status: Submitted [http://lists.busybox.net/pipermail/busybox/2019-April/087205.html]
+
+Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
+---
+ testsuite/dc.tests | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/testsuite/dc.tests b/testsuite/dc.tests
+index 1708a48..8c3af41 100755
+--- a/testsuite/dc.tests
++++ b/testsuite/dc.tests
+@@ -41,6 +41,9 @@ testing "dc complex without spaces (multiple args)" \
+ "16\n" \
+ "" ""
+
++optional FEATURE_DC_BIG
++# All tests below depend on FEATURE_DC_BIG
++
+ testing "dc read" \
+ "dc -finput" \
+ "2\n9\n1\n" \
+@@ -51,9 +54,6 @@ testing "dc read string" \
+ "2\nstr\n1\n" \
+ "1?2\nf" "[str]\n"
+
+-optional FEATURE_DC_BIG
+-# All tests below depend on FEATURE_DC_BIG
+-
+ testing "dc '>a' (conditional execute string) 1" \
+ "dc" \
+ "1\n9\n" \
+--
+2.7.4
+
diff --git a/meta/recipes-core/busybox/busybox_1.30.1.bb b/meta/recipes-core/busybox/busybox_1.30.1.bb
index 164f3ab3c3..ba76755d74 100644
--- a/meta/recipes-core/busybox/busybox_1.30.1.bb
+++ b/meta/recipes-core/busybox/busybox_1.30.1.bb
@@ -44,6 +44,7 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
file://0001-testsuite-check-uudecode-before-using-it.patch \
file://0001-testsuite-use-www.example.org-for-wget-test-cases.patch \
file://0001-du-l-works-fix-to-use-145-instead-of-144.patch \
+ file://0001-dc.tests-fix-two-test-case-to-also-depend-on-DC_BIG.patch \
"
SRC_URI_append_libc-musl = " file://musl.cfg "