aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/busybox/busybox_git.bb
diff options
context:
space:
mode:
authorJunling Zheng <zhengjunling@huawei.com>2015-06-07 07:52:19 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-11 23:55:42 +0100
commit66ec540dad77052bc2c1da3a87f875547600efad (patch)
tree4ed0c71ac9c0e7aebf78b65b0a1f06351d2047f7 /meta/recipes-core/busybox/busybox_git.bb
parent5252ab5910aa8fecaf988f43f882e2c4db30056d (diff)
downloadopenembedded-core-contrib-66ec540dad77052bc2c1da3a87f875547600efad.tar.gz
busybox: fix double free error for ifconfig
This patch backports a commit from upstream to fix a potential double free error when executing ifconfig circularly: http://git.busybox.net/busybox/commit/?id=a97777889328157bb7d06ec618bad16712a9c345. Thanks to Chen Gang for reporting and analyzing this bug. Signed-off-by: Junling Zheng <zhengjunling@huawei.com> Signed-off-by: Chen Gang <cg.chen@huawei.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-core/busybox/busybox_git.bb')
-rw-r--r--meta/recipes-core/busybox/busybox_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-core/busybox/busybox_git.bb b/meta/recipes-core/busybox/busybox_git.bb
index cee5b9171d..675e56afd0 100644
--- a/meta/recipes-core/busybox/busybox_git.bb
+++ b/meta/recipes-core/busybox/busybox_git.bb
@@ -36,6 +36,7 @@ SRC_URI = "git://busybox.net/busybox.git \
file://login-utilities.cfg \
file://recognize_connmand.patch \
file://busybox-cross-menuconfig.patch \
+ file://0001-ifconfig-fix-double-free-fatal-error-in-INET_sprint.patch \
"
EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX} SKIP_STRIP=y"