aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/busybox/busybox_git.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2013-11-29 20:15:45 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-11-29 16:27:03 +0000
commitd290bbe6d9826fbcfa2e0a7624886284697ed7eb (patch)
tree4ff438f7617ff581d7e6d1629becb9146b614e85 /meta/recipes-core/busybox/busybox_git.bb
parente2b62393497a0aaffb21161336a42249db61a10d (diff)
downloadopenembedded-core-contrib-d290bbe6d9826fbcfa2e0a7624886284697ed7eb.tar.gz
busybox: add busybox_git.bb recipe
Add busybox_git.bb recipe so that it would be easier to hack with busybox. Set DEFAULT_PREFERENCE to "-1" in the git recipe so that we still use the busybox_1.21.1.bb recipe by default. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/busybox/busybox_git.bb')
-rw-r--r--meta/recipes-core/busybox/busybox_git.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-core/busybox/busybox_git.bb b/meta/recipes-core/busybox/busybox_git.bb
new file mode 100644
index 0000000000..91ecff8212
--- /dev/null
+++ b/meta/recipes-core/busybox/busybox_git.bb
@@ -0,0 +1,53 @@
+require busybox.inc
+
+SRCREV = "e73f3c1d3d83699b723251f7e6a981021ce75475"
+# Lookout for PV bump too when SRCREV is changed
+PV = "1.21.1+git${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+SRC_URI = "git://busybox.net/busybox.git \
+ file://get_header_tar.patch \
+ file://busybox-appletlib-dependency.patch \
+ file://run-parts.in.usr-bin.patch \
+ file://watch.in.usr-bin.patch \
+ file://busybox-udhcpc-no_deconfig.patch \
+ file://find-touchscreen.sh \
+ file://busybox-cron \
+ file://busybox-httpd \
+ file://busybox-udhcpd \
+ file://default.script \
+ file://simple.script \
+ file://hwclock.sh \
+ file://mount.busybox \
+ file://syslog \
+ file://syslog-startup.conf \
+ file://syslog.conf \
+ file://busybox-syslog.default \
+ file://mdev \
+ file://mdev.conf \
+ file://umount.busybox \
+ file://defconfig \
+ file://stat-usr-bin.patch \
+ file://busybox-syslog.service.in \
+ file://busybox-klogd.service.in \
+ file://testsuite-du-du-k-works-fix-false-positive.patch \
+ file://fail_on_no_media.patch \
+ file://busybox-sulogin-empty-root-password.patch \
+ file://run-ptest \
+ file://inetd.conf \
+ file://inetd \
+ file://login-utilities.cfg \
+ file://busybox-list-suid-and-non-suid-app-configs.patch \
+ file://busybox-sed-fix-sed-clusternewline-testcase.patch \
+"
+
+EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX} SKIP_STRIP=y"
+
+do_install_ptest () {
+ cp -r ${B}/testsuite ${D}${PTEST_PATH}/
+ cp ${B}/.config ${D}${PTEST_PATH}/
+ ln -s /bin/busybox ${D}${PTEST_PATH}/busybox
+}
+
+DEFAULT_PREFERENCE = "-1"