aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/busybox/busybox_1.24.1.bb
diff options
context:
space:
mode:
authorJuro Bystricky <juro.bystricky@intel.com>2016-09-14 10:05:46 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-14 22:34:34 +0100
commita866a05e2c7d090a77aa6e95339c93e3592703a6 (patch)
tree89c79e4752f88e3aacd98279f81f66164eab0256 /meta/recipes-core/busybox/busybox_1.24.1.bb
parentd3d2d213076b50e88ddc7d4e418ea2ab61b92e67 (diff)
downloadopenembedded-core-contrib-a866a05e2c7d090a77aa6e95339c93e3592703a6.tar.gz
busybox: Avoid race building libbb
When building busybox, an occasional error was observed. The error is consistently the same: libbb/appletlib.c:164:13: error: 'NUM_APPLETS' undeclared (first use in this function) while (i < NUM_APPLETS) { The reason is the include file where NUM_APPLETS is defined is not yet generated (or is being modified) at the time libbb/appletlib.c is compiled. The attached patchset fixes the problem by assuring libb is compiled as the last directory. [YOCTO#10116] Signed-off-by: Juro Bystricky <juro.bystricky@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/busybox/busybox_1.24.1.bb')
-rw-r--r--meta/recipes-core/busybox/busybox_1.24.1.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-core/busybox/busybox_1.24.1.bb b/meta/recipes-core/busybox/busybox_1.24.1.bb
index f370451a3c..df0e131266 100644
--- a/meta/recipes-core/busybox/busybox_1.24.1.bb
+++ b/meta/recipes-core/busybox/busybox_1.24.1.bb
@@ -49,8 +49,10 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
file://CVE-2016-2147_2.patch \
file://ip_fix_problem_on_mips64_n64_big_endian_musl_systems.patch \
file://makefile-fix-backport.patch \
- file://parallel-make-fix.patch \
file://0001-sed-fix-sed-n-flushes-pattern-space-terminates-early.patch \
+ file://busybox-kbuild-race-fix-commit-d8e61bb.patch \
+ file://commit-applet_tables-fix-commit-0dddbc1.patch \
+ file://makefile-libbb-race.patch \
"
SRC_URI_append_libc-musl = " file://musl.cfg "