aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/busybox/busybox_1.22.1.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-01-22 10:39:46 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-02-02 11:22:12 +0000
commitb1ea3455379e38d4e56970505c05b4104d5f1234 (patch)
tree0900ad3eef7a6bd6d31d18abf0ce932e819da9cb /meta/recipes-core/busybox/busybox_1.22.1.bb
parent47208175027686339dd18df52b60ec2c43594918 (diff)
downloadopenembedded-core-contrib-b1ea3455379e38d4e56970505c05b4104d5f1234.tar.gz
busybox: upgrade to stable 1.22.1
Upgrade busybox to the stable release 1.22.1. During this upgrade, 9 patches are removed. Reasons are detailed below. The following 6 patches are removed as they have been merged. meta/recipes-core/busybox/busybox/busybox-lineedit-initialize-delptr.patch meta/recipes-core/busybox/busybox/busybox-list-suid-and-non-suid-app-configs.patch meta/recipes-core/busybox/busybox/busybox-sed-fix-sed-clusternewline-testcase.patch meta/recipes-core/busybox/busybox/busybox-sulogin-empty-root-password.patch meta/recipes-core/busybox/busybox/find-get-rid-of-nested-functions.patch meta/recipes-core/busybox/busybox/testsuite-du-du-k-works-fix-false-positive.patch The following three patches are removed because they are mainly about moving binaries from /bin to /usr/bin to make the update-alternative work correctly at rootfs time. We can easily solve this problem by changing recipes. There's no compelling reason why such patches are needed. meta/recipes-core/busybox/busybox/run-parts.in.usr-bin.patch meta/recipes-core/busybox/busybox/stat-usr-bin.patch meta/recipes-core/busybox/busybox/watch.in.usr-bin.patch (From OE-Core rev: fa282186d82e8fe3c590d4ea79e464116e5ceea2) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/busybox/busybox_1.22.1.bb')
-rw-r--r--meta/recipes-core/busybox/busybox_1.22.1.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-core/busybox/busybox_1.22.1.bb b/meta/recipes-core/busybox/busybox_1.22.1.bb
new file mode 100644
index 0000000000..ffc9435398
--- /dev/null
+++ b/meta/recipes-core/busybox/busybox_1.22.1.bb
@@ -0,0 +1,41 @@
+require busybox.inc
+
+SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
+ file://get_header_tar.patch \
+ file://busybox-appletlib-dependency.patch \
+ file://busybox-udhcpc-no_deconfig.patch \
+ file://find-touchscreen.sh \
+ file://busybox-cron \
+ file://busybox-httpd \
+ file://busybox-udhcpd \
+ file://default.script \
+ file://simple.script \
+ file://hwclock.sh \
+ file://mount.busybox \
+ file://syslog \
+ file://syslog-startup.conf \
+ file://syslog.conf \
+ file://busybox-syslog.default \
+ file://mdev \
+ file://mdev.conf \
+ file://umount.busybox \
+ file://defconfig \
+ file://busybox-syslog.service.in \
+ file://busybox-klogd.service.in \
+ file://fail_on_no_media.patch \
+ file://run-ptest \
+ file://inetd.conf \
+ file://inetd \
+ file://login-utilities.cfg \
+"
+
+SRC_URI[tarball.md5sum] = "337d1a15ab1cb1d4ed423168b1eb7d7e"
+SRC_URI[tarball.sha256sum] = "ae0b029d0a9e4dd71a077a790840e496dd838998e4571b87b60fed7462b6678b"
+
+EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX} SKIP_STRIP=y"
+
+do_install_ptest () {
+ cp -r ${B}/testsuite ${D}${PTEST_PATH}/
+ cp ${B}/.config ${D}${PTEST_PATH}/
+ ln -s /bin/busybox ${D}${PTEST_PATH}/busybox
+}